Page 1 of 2

file names missing or not showing correctly in Import>Audio

Permanent link to this postPosted: Fri Mar 17, 2017 12:53 am
Posted by labud
03.29.2017 NOTE: Out of deparation I tried the rpm 2.1.0 version from here:
http://packman.links2linux.org/package/286 installed it
and have edited a few songs thru it and it seems to be working. [as in it puts the .mp3 extension on the edited song. I don't know what 'bugs' were in 2.1.0 but they don't seem to be effecting my work yet. So as much as I would like to carryon solving this problem, I think I will leave it here and get some work done. I will keep my eyes open for any file name discrepancies or files that don't show in the selection window. and post back here.
Thank You.





openSUSE Leap 42.2 64-bit, KDE Plasma 5.8.3, Audacity 2.1.2 installed thru Yast

Here I am starting a post as suggested from my other post: http://forum.audacityteam.org/viewtopic.php?f=48&t=95221&p=324160#p324160
It isn't known about. And I don't see it here: https://bugzilla.opensuse.org/buglist.c ... h=audacity.
Do the files that are missing or mis-spelt always contain accented characters or symbols?


3 part issue with File>Import>Audio

Part 1
Sometimes when I try to import a song [File>Import>Audio] and the import selection window opens I cannot find the file I am looking for.
I can see it in my file manager[Dolphin], but not in the Import selection window. [It is in my files in the correct folder]
My only means of getting the file into audacity is to drag & drop, whereas I usually do the File>Import>Audio method.
Being a creature of habit I like to do things using the same method.

Part 2
At times the file names I see in the import selection window do not look the same as in the file manager[Dolphin], sometimes they are mis-spelled or add extra letters where they are not this way in the file manager. Characters/Symbols I commonly use in my file naming are ( - , & [ ] )
[e.g.] Amber Digby - Heart, I am ashamed of you 007-.mp3 would Look like Aamber Digby - Heart, I am ashamed of you 007-.mp3
There were other but I didn't write them down.
I guess this [Part 2] could be caused by Characters/Symbols in the file name, but [Part1] the file simply isn't listed.

Part 3
This may not be anything but different sorting order, but the file names in Audacity aren't always sorted the same as in Dolphin file manager.
IMG_20170316_164618.jpg
IMG_20170316_164618.jpg (1.22 MiB) Viewed 677 times


[e.g.] -
File>Import>Audio is on the left.
Bennys come before Bens

Dolphin file manager is on the right.
Bens come before Bennys

Re: file names missing or not showing correctly in Import>Au

Permanent link to this postPosted: Fri Mar 17, 2017 1:57 am
Posted by steve
How do you enter the names? Do you type them, or copy and paste?
Are you using an English keyboard?

Not enough information in "Part 1" to diagnose the problem, but given "Part 2" I'd guess that it could be due to character encoding.

Part 2: Yes, probably due to non-Unicode characters, but more information needed to confirm if that is the case.

Part 3: What are you showing us? Where does it say "Bennys" ?
On Debian I'm seeing "Ben 1" before "Benny 1" in both Thunar and Audacity when sorted by Name ("space" coming before "n").
I'm also seeing "AA2" before "aa3" in Thunar, but "aa3" before "AA2" in Audacity.
Firefox and Scite order in the same way as Audacity. Xfce Terminal orders in the same way as Thunar.

Re: file names missing or not showing correctly in Import>Au

Permanent link to this postPosted: Fri Mar 17, 2017 2:11 pm
Posted by labud
How do you enter the names? Do you type them, or copy and paste?
Are you using an English keyboard?

Usually I select them from the File>Import>Audio> window, but if they are not there I drag & drop to Audacity window, when I am opening the file in Audacity.
When I am exporting [File>Export Audio][after corrections] I copy the file name [in Dolphin File Manager] and paste it in the SAVE window[Audacity>File>Export Audio] to change the .aiff to .mp3.
Yes I am using a simple Microsoft keyboard [US English].

Part 3: What are you showing us? Where does it say "Bennys" ?

I am showing you that in the window on the left [Audacity>File>Import>Audio] the file name
"Benny Berry - Helen's Arms 008-gbl13.mp3" comes before "Ben Saunders - Dry Your Eyes 008-GBL27.mp3"

while in the window on the right [Dolphin File Manager] it is the reverse -

"Ben Saunders - Dry Your Eyes 008-GBL27.mp3" [b]comes before[/b] "Benny Berry - Helen's Arms 008-gbl13.mp3".

What I am asking is why is that? Shouldn't the sort criteria be the same in the file manager and in the selection window, because after all the selection window is just a mirror of the file manager? Isn't it?

Re: file names missing or not showing correctly in Import>Au

Permanent link to this postPosted: Fri Mar 17, 2017 6:12 pm
Posted by steve
labud wrote:Usually I select them from the File>Import>Audio> window, but if they are not there I drag & drop to Audacity window, when I am opening the file in Audacity.
When I am exporting [File>Export Audio][after corrections] I copy the file name [in Dolphin File Manager] and paste it in the SAVE window[Audacity>File>Export Audio] to change the .aiff to .mp3.

I'm trying to understand where the characters that form the name of the file come from. You're saying that the name is copied from the file that you import(?) but where does the name of that file come from? Are the "original" files downloaded from the internet, bought from Amazon, downloaded from YouTube, something else..?

Re: file names missing or not showing correctly in Import>Au

Permanent link to this postPosted: Fri Mar 17, 2017 6:19 pm
Posted by steve
labud wrote:because after all the selection window is just a mirror of the file manager? Isn't it?

The selection window is a WxWidgets file browser window. An application's file browser window is part of that application and not dependent on the system's file browser. If you install Thunar file manager, I expect that it will behave the same on your machine as it does on mine, and show different alphanumeric ordering to Dolphin.

Re: file names missing or not showing correctly in Import>Au

Permanent link to this postPosted: Fri Mar 17, 2017 10:58 pm
Posted by labud
I'm trying to understand where the characters that form the name of the file come from. You're saying that the name is copied from the file that you import(?) but where does the name of that file come from? Are the "original" files downloaded from the internet, bought from Amazon, downloaded from YouTube, something else..?


I created the file names when I loaded the music on my computer. The music is from my CD's and Vinyl records. The only alphanumeric characters I use are - , & [] ()
Other than that is is all upper and lower case.

Re: file names missing or not showing correctly in Import>Au

Permanent link to this postPosted: Sat Mar 18, 2017 3:12 pm
Posted by Gale Andrews
You could compile Audacity 2.1.1 against wxWidgets 2.8.12 and see if 2.1.1 had the issue. If it doesn't, then it might be a wxWidgets problem, but I am guessing it will be the same in 2.1.1.

What are some examples of a file name as shown in the file manager that shows there but not in Audacity's import dialogue? I can't see properly from your image because of the need to scroll up and down and side to side. It might be better to use normal per-window operating system screenshots for this, and post separate images of Audacity import and the file manager.


Gale

Re: file names missing or not showing correctly in Import>Au

Permanent link to this postPosted: Sun Mar 19, 2017 1:45 am
Posted by labud
You could compile Audacity 2.1.1 against wxWidgets 2.8.12 and see if 2.1.1 had the issue. If it doesn't, then it might be a wxWidgets problem, but I am guessing it will be the same in 2.1.1.


What about Audacity 2.1.0? You suggested trying to go back to that version in the other post.
And would I also have to compile it against wxWidgets? I am a little unsure how to do that, but with direction will try.

I see by google that wxWidgets is program[?] for making GUI[?], but other than that I don't know.

Re: file names missing or not showing correctly in Import>Au

Permanent link to this postPosted: Sun Mar 19, 2017 3:48 am
Posted by Gale Andrews
labud wrote:
You could compile Audacity 2.1.1 against wxWidgets 2.8.12 and see if 2.1.1 had the issue. If it doesn't, then it might be a wxWidgets problem, but I am guessing it will be the same in 2.1.1.


What about Audacity 2.1.0? You suggested trying to go back to that version in the other post.

Either 2.1.0 or 2.1.1 should be a good test for the purpose of testing the file dialogue. What happened was that in 2.1.2 we changed to using wxWidgets 3.0.2 and that change caused a lot of Audacity bugs.

labud wrote:And would I also have to compile it against wxWidgets?

Yes, explicitly compile wxWidgets 2.8.12 (wxGTK, 13 MB) from the bottom of http://wxwidgets.org/downloads/

Compiling wxWidgets should just involve
Code: Select all
./configure --enable-shared

then
Code: Select all
make

and
Code: Select all
sudo make install

That should install wxWidgets to usr/local.

Then build Audacity. There is a reasonable overview of what is required in terms of dependencies here:
http://wiki.audacityteam.org/wiki/Developing_On_Linux.

Audacity should find the install of wxWidgets in usr/local, but if not, you can add the path to the WX_CONFIG file in your 2.8.12 wxWidgets installation to your configure command as described in the link above.


Gale

Re: file names missing or not showing correctly in Import>Au

Permanent link to this postPosted: Wed Mar 22, 2017 8:42 pm
Posted by labud
I have wxWidgets 3.0 devel already installed on opensuse 42.2 will that conflict with wxWidgets 2.8.12?