Inactive input level slider

Help for Audacity 2.x.x on GNU/Linux.

ImageThis forum is for Audacity 2.x.x on GNU/Linux and Unix-like operating systems.
Please state which version of Linux you are using, the exact three-section version number of Audacity from Help > About Audacity... and whether you installed your distribution's release or daily version of Audacity or compiled Audacity from source code.

Audacity 1.2.x and 1.3.x are obsolete and no longer supported. If you still have those versions, please upgrade at https://www.audacityteam.org/download/.
The old forums for those versions are now closed, but you can still read the archives of the 1.2.x and 1.3.x forums.

Inactive input level slider

Permanent link to this post Posted by batisse » Tue Jan 03, 2017 7:46 am

Hi the experts, and happy new year!

I am new with both Linux and Audacity (before I used Windows and Goldwave). English is not my native language ;)

I have installed Audacity and PulseAudio, as I wish to record and treat radio stream. Though I have now found a way to act in the input volume level, via the PulseAudio volume control program, I am annoyed by the fact that the input level sliding potentiometer on the Audacity dashboard appears to be dead: blocked in extreme right position and impossible to move.

How can I solve that problem, keeping in mind that I am not an expert in programming and so on....

After that I will come again with a matter of tooltip characters colour (white on pale grey is far from ideal...)

Thanks in advance and best regards :)
batisse
 
Posts: 2
Joined: Mon Jan 02, 2017 12:27 pm
Operating System: Linux *buntu

Re: Inactive input level slide

Permanent link to this post Posted by Gale Andrews » Tue Jan 03, 2017 3:06 pm

The recording level slider is deliberately disabled because our PortAudio and PortMixer interfaces don't (yet) properly support PulseAudio, and ALSA-lib's PulseAudio plugin doesn't support its mixer control. This means that if the Audacity recording level slider was enabled, all it would do is scale down an excessively loud (clipped) signal, merely making the distortion quieter. That would be dangerous and misleading.

What version of Ubuntu and Audacity are you using?

I suggest you install PulseAudio Volume Control (pavucontrol) from your repository if you have not already done so, then you can select the input and control its level there.

Or choose the (hw) device as recording device in Audacity's Device Toolbar instead of choosing the pulse recording device, assuming you are recording a physical radio. Then hopefully the Audacity recording level slider would ungrey.

If you are recording internet radio, see this article: Recording Computer Playback on Linux.


Gale
________________________________________FOR INSTANT HELP: (Click on Link below)
* * * * * Tips * * * * * Tutorials * * * * * Quick Start Guide * * * * * Audacity Manual
Gale Andrews
Quality Assurance
 
Posts: 26089
Joined: Fri Jul 27, 2007 12:02 am
Operating System: Windows 10

Re: Inactive input level slider

Permanent link to this post Posted by batisse » Tue Jan 03, 2017 5:19 pm

Thanks for your quick answer, which gives a clear reason to my problem! I do listen webradios, so I understand that for the time being I must manage without that slider... No problem.

The console tells me that I avail an ubuntu 16.04.1 LTS Is that correct?
Audacity is the 2.1.2 issue.

Thanks again. I am impressed ;)
batisse
 
Posts: 2
Joined: Mon Jan 02, 2017 12:27 pm
Operating System: Linux *buntu

Re: Inactive input level slider

Permanent link to this post Posted by fredex » Wed Oct 04, 2017 11:35 am

Reply to Gale's post:

I have a Behringer UFO202 USB "sound card", which I hope to use to record from a phonograph and from a tape player. (I've not been able to get sound input to work, at all, on my system for recording purposes, so I purchased this device hoping it would allow me to do it.)

So, I saw your posting above and tried doing what you suggest, re "choose the (hw) device...". First time I did that, I saw the USB device in the list, could select it and then the recording slider worked. Before trying to record, I did some experimentation, i.e., chose a different device (I think it was pulse) and the volume slider became inactive (as it apparently should have, according to your post). thereafter I have not had the USB device shown in the list of devices. I've tried everything I can think of: unplug the USB device, reinsert (no go); stop and restart Audacity (no go), combinations of those two steps in different orders (no go), and even a system reboot. still no go. The usb device no longer shows up in Audacity.

I have Audacity 2.1.1 for Centos-7, from the epel repo.

it's not a total loss: I can record by using pulse, but I have to turn up all the record/playback levels along the chain, and even then I can't get the record level up into the high end of the safe region. I suppose I could insert an audio preamp and crank its volume.

I'd LIKE to be able to use the USB device as the input device, but if I can't, I can't. but I'm puzzled by the fact that it appeared once then disappeared and won't reappear.

Suggestions would be welcome.

thanks in advance!
fredex
 
Posts: 5
Joined: Wed Oct 04, 2017 12:27 am
Operating System: Linux Fedora/RHEL

Re: Inactive input level slider

Permanent link to this post Posted by steve » Wed Oct 04, 2017 11:55 am

Audacity only looks for audio devices when Audacity is launched, and when you explicitly tell it to rescan for new audio devices (in "Transport" menu http://manual.audacityteam.org/man/transport_menu.html). When using a USB device, connect the device first and then launch Audacity. The USB device should then be available in the device toolbar.
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 45315
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: Inactive input level slider

Permanent link to this post Posted by fredex » Thu Oct 05, 2017 7:16 pm

Steve, thanks for the reply.

Trouble is, when started as you describe, pavucontrol shows the device, audacity does not. I did once, but never again since, in many attempts.
fredex
 
Posts: 5
Joined: Wed Oct 04, 2017 12:27 am
Operating System: Linux Fedora/RHEL

Re: Inactive input level slider

Permanent link to this post Posted by steve » Thu Oct 05, 2017 11:55 pm

1) Log out
2) Log back in
3) Ensure that the USB device is connected
4) Launch Audacity.
Is the USB device listed in the device toolbar?
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 45315
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: Inactive input level slider

Permanent link to this post Posted by fredex » Sat Oct 07, 2017 3:41 pm

well. this is embarrassing. without doing the log out/in bit, I fire up audacity, and there it is, right in the toolbar where it belongs.

as I think back on what I've been doing this past week I can't say for sure that it hasn't been there and that I was just too stupid/blind to see it. but I don't think it has been there.

but now it is.

I note that even when I select it, that the recording level slider remains greyed out, and the first time I selected it (as mentioned in my earlier posts) the slider was accessible.

but I'll do some recording tests this afternoon and see how it works.

thanks for your guidance!

Fred
fredex
 
Posts: 5
Joined: Wed Oct 04, 2017 12:27 am
Operating System: Linux Fedora/RHEL

Re: Inactive input level slider

Permanent link to this post Posted by steve » Sun Oct 08, 2017 12:03 pm

When you select (in the device toolbar) a specific named device that has a "(hw:..)" suffix, you are telling Audacity to access the device directly via its ALSA drivers, bypassing PulseAudio. Generally this is the preferred option for Audacity, but there is a limitation: For most hardware, the ALSA drivers will only support one client application at a time, so if any other software is accessing the device, then that device will not be available to Audacity.

The other issue affecting USB devices is that Audacity only looks for audio devices when Audacity is launched. If the USB device is connected while Audacity is running, Audacity will not see it until you either: (a) Close and restart Audacity (b) "Transport menu > Rescan Audio Devices".

fredex wrote:I note that even when I select it, that the recording level slider remains greyed ou

That is normal. USB devices don't have software gain control. Some operating systems will provide a kind of fake gain control by scaling the digital signal (exactly equivalent to using Audacity's "Amplify" effect but in real-time during recording. ALSA on Linux, and Core Audio on Mac don't provide gain control for USB devices.

fredex wrote:the first time I selected it (as mentioned in my earlier posts) the slider was accessible.

Mystery :? It's not supposed to be able to do that.
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 45315
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: Inactive input level slider

Permanent link to this post Posted by fredex » Sun Dec 03, 2017 2:15 pm

A much belated follow-up:

Thanks for your assistance I have been able to capture good audio from a cassette deck and have converted a number of tapes. thanks!

but one thing still puzzles me:
To make it work I had to choose pulse. If I chose the USB device, it allowed only mono recording. If there is a way to enable stereo with that device, it wasn't obvious to me.

Any further thoughts on this?

thanks again!

Fred
fredex
 
Posts: 5
Joined: Wed Oct 04, 2017 12:27 am
Operating System: Linux Fedora/RHEL


Return to GNU/Linux and Unix-like



Who is online

Users browsing this forum: No registered users and 4 guests