Page 1 of 1

Audacity before 2.1.2 is unstable built with wxWidgets 3.x

Permanent link to this postPosted: Sat Apr 04, 2015 5:32 pm
Posted by Gale Andrews
Some Linux distributions are supplying Audacity builds that are unstable because built with wxWidgets 3.x.

Audacity 2.1.1 and earlier do not support wxWidgets 3.x versions, therefore if Audacity is built with such a version there will be many bugs. This applies for example to Ubuntu "Daily Builds", Ubuntu Vivid and Debian Jessie. Please check Help > About Audacity... then the "Build Information" tab to check the version of wxWidgets that Audacity is built with.

If you find bugs in Audacity built with wx3 that are not already known about, please post on the Linux board of this Forum or write to our feedback address.

To avoid issues you can build wxWidgets 2.8.12 then compile Audacity against wxWidgets 2.8.12.

On Ubuntu 12.04, Ubuntu 14.04, Ubuntu 14.10, Ubuntu 15.04 and Linux Mint 13 and 17, you can install the Audacity 2.1.0 release built correctly against wxWidgets 2.8.12 by installing the PPA at https://launchpad.net/~ubuntuhandbook1/+archive/ubuntu/audacity.


Gale