env PULSE_LATENCY_MSEC=30 audacity

Help for Audacity 2.x.x on GNU/Linux.

ImageThis forum is for Audacity 2.x.x on GNU/Linux and Unix-like operating systems.
Please state which version of Linux you are using, the exact three-section version number of Audacity from Help > About Audacity... and whether you installed your distribution's release or daily version of Audacity or compiled Audacity from source code.

Audacity 1.2.x and 1.3.x are obsolete and no longer supported. If you still have those versions, please upgrade at https://www.audacityteam.org/download/.
The old forums for those versions are now closed, but you can still read the archives of the 1.2.x and 1.3.x forums.

env PULSE_LATENCY_MSEC=30 audacity

Permanent link to this post Posted by vistad » Sat Aug 23, 2014 12:52 pm

I am on Linux Mint 17, 32 Mate.

Thank you Gale for suggesting to start Audacity from the Terminal with the command
env PULSE_LATENCY_MSEC=30 audacity
- it played fine. Now folks, please help me implement this fix permanently!

I looked through the forums and noticed my problem is well known - however I didn't find the clue how to implement this fix permanently.

My initial Preferences-Recording-Latency settings were
Audio to buffer = 100
Latency correction = -130

I changed Latency correction to 30, as Gale suggested. Audacity started playing mp3 files fine, but the cursor changed smooth motion to jumping by 1/4 inch intervals. And Audio to buffer by itself turned into 31000.
Please advise how to fix the problem.
Also I found that I added development PPA - please advise which PPA to use for Audacity stable.

Gale wrote:

I am not sure why the Linux Mint repository is carrying unreleased versions of
Audacity - did you enable unofficial or PPA sources?

Anyway, the problem probably isn't version-specific and is likely due to the
interaction of pulseaudio and Audacity.

You can select the (hw) playback device - so bypassing pulse.

Because you are now trying to access the device directly through ALSA, if any
other program is accessing the device then it will not be available
for Audacity.

Also this denies exclusive access of a device to PulseAudio, so other
applications
using PulseAudio will not be able to use that device.

Or you can try launching Audacity at a terminal with

env PULSE_LATENCY_MSEC=30 audacity
vistad
 
Posts: 1
Joined: Sat Aug 23, 2014 12:24 pm
Operating System: Please select

Re: env PULSE_LATENCY_MSEC=30 audacity

Permanent link to this post Posted by steve » Sat Aug 23, 2014 4:22 pm

vistad wrote:I looked through the forums and noticed my problem is well known - however I didn't find the clue how to implement this fix permanently.

If you are launching Audacity from a launcher or menu item, edit the "properties".
For example, if the launcher "command" is currently:
Code: Select all
audacity

change it to:
Code: Select all
env PULSE_LATENCY_MSEC=30 audacity
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 45396
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: env PULSE_LATENCY_MSEC=30 audacity

Permanent link to this post Posted by steve » Sat Aug 23, 2014 4:24 pm

vistad wrote:And Audio to buffer by itself turned into 31000.
Please advise how to fix the problem.

Go back into preferences and delete the "31000". Then, type in "100" (without quotes).
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 45396
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: env PULSE_LATENCY_MSEC=30 audacity

Permanent link to this post Posted by steve » Sat Aug 23, 2014 4:25 pm

vistad wrote:Also I found that I added development PPA - please advise which PPA to use for Audacity stable.

It is normally recommended to use the official repositories for your distribution and not use PPAs.

PPA repositories may be suitable for advanced users that are able to sort out any problems that may occur from using them.
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 45396
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: env PULSE_LATENCY_MSEC=30 audacity

Permanent link to this post Posted by Gale Andrews » Sat Aug 23, 2014 7:44 pm

vistad wrote:My initial Preferences-Recording-Latency settings were
Audio to buffer = 100
Latency correction = -130

I changed Latency correction to 30, as Gale suggested.

No I wrote only what you cited further down your post.

"Latency correction" in Recording Preferences does nothing except move a recorded track left or right after you have finished recording against another track. It does not affect playback or recording at all.


Gale
________________________________________FOR INSTANT HELP: (Click on Link below)
* * * * * Tips * * * * * Tutorials * * * * * Quick Start Guide * * * * * Audacity Manual
Gale Andrews
Quality Assurance
 
Posts: 26089
Joined: Fri Jul 27, 2007 12:02 am
Operating System: Windows 10


Return to GNU/Linux and Unix-like



Who is online

Users browsing this forum: No registered users and 6 guests