Window … Bring all to front

Help for Audacity 2.x.x on Mac OS X.

ImageThis forum is for Audacity 2.x.x on Mac OS X 10.4 and later.
Please state which version of macOS you are using,
and the exact three-section version number of Audacity from "Audacity menu > About Audacity".


Audacity 1.2.x and 1.3.x are obsolete and no longer supported. If you still have those versions, please upgrade at https://www.audacityteam.org/download/.
The old forums for those versions are now closed, but you can still read the archives of the 1.2.x and 1.3.x forums.

Window … Bring all to front

Permanent link to this post Posted by DJDemon » Fri Dec 22, 2017 11:14 pm

macOS Sierra 10.12.6
Audacity 2.2.1 (just upgraded from 2.1.3)

First, let me thank you for the new version! Unfortunately, I ran into a new (?) problem. Well, it may have existed already with 2.1.3, but only now I have taken the time to reproduce it.

1) Open Audacity
2) Minize the window (yellow dot or cmd-m).
3) Menu: Window -> Bring all to front (*)
4) Audacity crashes

(*) or whatever it is named in English; on my German macOS it's named "Alle nach vorne bringen"

Notes:
• When the are multiple project windows, this will happen when at least one window is minimized.
• No such problem on OSX 10.8.5 !

Is this a known issue or should I report it as a bug, using the official way (eMail)?
DJDemon
 
Posts: 25
Joined: Fri Jul 17, 2015 12:14 pm
Operating System: OS X 10.11 El Capitan or later (macOS)

Re: Window … Bring all to front

Permanent link to this post Posted by waxcylinder » Sat Dec 23, 2017 2:51 pm

Works fine for me on macOS 10.13.2 High Sierra

a) with a single project minimized
b) with multiple projects minimized

So no bug AFAICT

WC
________________________________________FOR INSTANT HELP: (Click on Link below)
* * * * * FAQ * * * * * Tutorials * * * * * Audacity Manual * * * * * Audacity Wiki * * * * *
waxcylinder
Forum Staff
 
Posts: 9283
Joined: Tue Jul 31, 2007 11:03 am
Location: Manchester, UK
Operating System: Windows 10

Re: Window … Bring all to front

Permanent link to this post Posted by DJDemon » Sat Dec 23, 2017 3:46 pm

waxcylinder wrote:So no bug …

"No bug"? On Sierra it is perfectly reproducible! And, no, I won't change to High Sierra in the near future…
DJDemon
 
Posts: 25
Joined: Fri Jul 17, 2015 12:14 pm
Operating System: OS X 10.11 El Capitan or later (macOS)

Re: Window … Bring all to front

Permanent link to this post Posted by billw58 » Sat Dec 23, 2017 4:23 pm

Please try resetting your Audacity configuration.

Go to ~/Library/Application Support/audacity. Delete the file "audacity.cfg". Start Audacity and do your steps.

-- Bill
billw58
Forum Staff
 
Posts: 3747
Joined: Wed Aug 12, 2009 2:10 am
Location: Waterloo, Ontario
Operating System: OS X 10.11 El Capitan or later (macOS)

Re: Window … Bring all to front

Permanent link to this post Posted by DJDemon » Sat Dec 23, 2017 7:14 pm

Wow! Thank you very much; at first sight this seems to fix the problem.

Do you have an idea, what the offending line(s) in the cfg file could be?
Mybe I can edit it, rather than recreate all my precious settings.
DJDemon
 
Posts: 25
Joined: Fri Jul 17, 2015 12:14 pm
Operating System: OS X 10.11 El Capitan or later (macOS)

Re: Window … Bring all to front

Permanent link to this post Posted by billw58 » Sat Dec 23, 2017 8:35 pm

This will probably do it. Open audacity.cfg in TextEdit. Search for Window. Delete everything between [Window] (including [Window]) and the next occurrence of "[".

-- Bill
billw58
Forum Staff
 
Posts: 3747
Joined: Wed Aug 12, 2009 2:10 am
Location: Waterloo, Ontario
Operating System: OS X 10.11 El Capitan or later (macOS)

Re: Window … Bring all to front

Permanent link to this post Posted by DJDemon » Sat Dec 23, 2017 8:46 pm

Thank you! But: no success
DJDemon
 
Posts: 25
Joined: Fri Jul 17, 2015 12:14 pm
Operating System: OS X 10.11 El Capitan or later (macOS)

Re: Window … Bring all to front

Permanent link to this post Posted by billw58 » Sun Dec 24, 2017 3:21 pm

DJDemon wrote:Thank you! But: no success

Then I am at a loss.
-- Bill
billw58
Forum Staff
 
Posts: 3747
Joined: Wed Aug 12, 2009 2:10 am
Location: Waterloo, Ontario
Operating System: OS X 10.11 El Capitan or later (macOS)


Return to Mac OS X



Who is online

Users browsing this forum: No registered users and 2 guests