Strange sound

Help for Audacity 2.x.x on Mac OS X.

ImageThis forum is for Audacity 2.x.x on Mac OS X 10.4 and later.
Please state which version of OS X you are using, the exact three-section version of Audacity from Audacity > About Audacity and whether you obtained the .dmg installer or the zip.

Audacity 1.2.x and 1.3.x are obsolete and no longer supported. If you still have those versions, please upgrade at https://www.audacityteam.org/download/.
The old forums for those versions are now closed, but you can still read the archives of the 1.2.x and 1.3.x forums.

Strange sound

Permanent link to this post Posted by henrikhall » Sun May 14, 2017 7:51 am

I am on MacOS 10.11.6, using Audacity 2.1.3, downloaded as .dmg. Sound is transported from my device into Audacity, but not the right sound, just a strange noise, indicating that the sound is compromised somewhere en route.
Long story: I bought a simple Cassette to MP3 converter two years ago and back then managed to transfer some old cassette tapes successfully into Audacity and from there into iTunes. Since then, the converter has been unused until yesterday when I picked it up again and couldn't make it work properly. The cassette player works as it should, i e I can listen to cassettes on it, using earphones plugged directly into the player. In Audacity, however, I just get this rather unpleasant noise. Since the noise somehow follows what is played on the cassette (when the cassette player is silent, Audacity is silent), I draw the conclusion that the sound is somehow being distorted somewhere in the process or that Audacity or my computer is not interpreting the signal from the player correctly. Since I used the player last time, I have upgraded my OS, so I started by upgrading Audacity (from 2.0), but that didn't change anything. Looking through the Audacity trouble-shooting pages, the only possible solution I could find, was that the cord between the player and the computer might be malfunctioning. This sounds strange since the player and the cord have been absolutely untouched for the last two years, so before rushing off to buy a new cord, I thought I'd ask here if there could be anything else I could try. I have changed a few of the settings in Audacity randomly, such as sampling format and sampling frequency, but with no success. In fact, most settings can not be changed at all.
Thankful for any hints and help, Henrik Hall, Sweden
henrikhall
 
Posts: 7
Joined: Sun May 14, 2017 7:23 am
Operating System: OS X 10.11 El Capitan or later (macOS)

Re: Strange sound

Permanent link to this post Posted by Gale Andrews » Sun May 14, 2017 1:13 pm

You should understand the simple "converter", if cheap, will be just that - cheap junk. Many of these are supplied with USB cables that don't work in the first place or fail after a few uses. It is not an Audacity issue.

You could also try rebooting the Mac.

If your Mac has a stereo Line In, you could connect from the headphones out of the converter to the Line In of the Mac using a stereo TRS to stereo TRS cable, then set Audacity to record from LIne In. This bypasses the USB connection.


Gale
________________________________________FOR INSTANT HELP: (Click on Link below)
* * * * * Tips * * * * * Tutorials * * * * * Quick Start Guide * * * * * Audacity Manual
Gale Andrews
Quality Assurance
 
Posts: 26093
Joined: Fri Jul 27, 2007 12:02 am
Operating System: Windows 10

Re: Strange sound

Permanent link to this post Posted by henrikhall » Sun May 14, 2017 7:47 pm

Thanks! Will try that. Might be worth buying a new cable after all.
henrikhall
 
Posts: 7
Joined: Sun May 14, 2017 7:23 am
Operating System: OS X 10.11 El Capitan or later (macOS)

Re: Strange sound

Permanent link to this post Posted by kozikowski » Mon May 15, 2017 12:10 am

This is the cable.

Image

And the connection is the one on the left.

Image

Circle with two black arrows. That's the only connection that works. There was a brief product time when the tiny 13" Mac Book Pro had one socket and you could steer it to record stereo or play stereo in System Preferences.

That's been a while and I think the Mini is the only one left with a dedicated Stereo Line-In. Take a look.

Koz
kozikowski
Forum Staff
 
Posts: 37721
Joined: Thu Aug 02, 2007 5:57 pm
Location: Los Angeles
Operating System: OS X 10.9 Mavericks

Re: Strange sound

Permanent link to this post Posted by henrikhall » Mon May 15, 2017 8:35 am

Thanks! I am really glad for your help, since the manual for the cassette player is not half as helpful as you are. We have a couple of older Macs in the family which are still running, so one of them will surely work!
henrikhall
 
Posts: 7
Joined: Sun May 14, 2017 7:23 am
Operating System: OS X 10.11 El Capitan or later (macOS)

Re: Strange sound

Permanent link to this post Posted by henrikhall » Fri May 19, 2017 6:57 am

Before rushing out to buy new cables, I tried one more thing: an older computer. It worked! Obviously there was nothing wrong with my cable (or any of the other cables of the same kind which I found in the house and which didn't work on my newer computer either), nor with the USB port. True, using another type of cable and port could potentially have produced an even better result, but I am not chasing best quality here, I just want the basic function. And I got it on a computer running MacOS 10.5.8 with Audacity 2.1.1. To me that sounds like a compatibility problem. What do you think? It is a known fact that Audacity does not work with Sierra (10.12). Perhaps Capitan (10.11) should be added to that list?
henrikhall
 
Posts: 7
Joined: Sun May 14, 2017 7:23 am
Operating System: OS X 10.11 El Capitan or later (macOS)

Re: Strange sound

Permanent link to this post Posted by Gale Andrews » Fri May 19, 2017 10:15 am

henrikhall wrote:It is a known fact that Audacity does not work with Sierra (10.12).

The known problems with Audacity on Sierra have nothing to do with audio recording. See: http://wiki.audacityteam.org/wiki/Partial_Support_for_Mac_Sierra_in_2.1.3.

henrikhall wrote:Perhaps Capitan (10.11) should be added to that list?

No. How long was it since you rebooted the Mac running 10.11? Are you connected into an empty USB port on this computer? Have you tried a different USB port? Have you turned off Wi-Fi? If the computer uses a battery, have you switched to battery power?

A possible proof of an Audacity problem would be to record to GarageBand under the exact same circumstances and not find the strange noise. You have not attached a sample of the noise, so we can't form an opinion on it.
Please see how to attach files to forum posts.

However blaming Audacity is unlikely to be a route to solving the problem. It just records what the system gives it.


Gale
________________________________________FOR INSTANT HELP: (Click on Link below)
* * * * * Tips * * * * * Tutorials * * * * * Quick Start Guide * * * * * Audacity Manual
Gale Andrews
Quality Assurance
 
Posts: 26093
Joined: Fri Jul 27, 2007 12:02 am
Operating System: Windows 10

Re: Strange sound

Permanent link to this post Posted by cyrano » Sun May 21, 2017 12:14 pm

If you're on Sierra, it could be wise to install the latest update (10.12.5). Apple mentions fixing USB and Bluetooth audio, especially for USB or BT connected headphones.

As a plus, you also get about 30 holes in OSX plugged... 8-)
cyrano
 
Posts: 1267
Joined: Fri Apr 17, 2015 11:54 pm
Operating System: OS X 10.9 Mavericks

Re: Strange sound

Permanent link to this post Posted by henrikhall » Mon May 22, 2017 7:36 pm

It was never my intention to blame Audacity. If I did so by mistake, I apologize. I have the deepest respect for all people who spend their time and knowledge creating free-ware for all of the rest of us, who don't have half the skills required for that.
To me, a compatibility problem is not necessarily anyones fault, it is just simply very difficult to make all the components of very many different software work together, while at the same time satisfying the users demands for new and improved features.
I am also sorry for not checking the "Sierra problem" well enough. Thanks for pointing out that the issues with Sierra were so limited and not significant in this case.
Now for possible solutions. I have added a short sound clip to demonstrate what I am experiencing (thanks for the suggestion to do so). In fact, this clip comes from Garageband, which gives me just about the same non-music that Audacity gives me. Thus, we can finally and for good rule out that this should be an Audacity problem (thanks for not kicking me out of the forum right away).
My current computer does not have the "two arrow input", so I have not been able to try using another type of cable, but I did try both USB ports. They are empty in the sense that nothing else is plugged into them. Wi-fi turned off made no difference, neither running the computer on battery only. I restarted the computer when I first experienced these problems, but I am not sure whether that is the same thing as rebooting.
I am not desperate to find the solution anymore, since I can use my older computer, but I am still grateful for hints leading to a solution. Maybe others are too?
Attachments
Kassetttest.mp3
Sample of strange sound
(121.14 KiB) Downloaded 15 times
henrikhall
 
Posts: 7
Joined: Sun May 14, 2017 7:23 am
Operating System: OS X 10.11 El Capitan or later (macOS)

Re: Strange sound

Permanent link to this post Posted by kozikowski » Mon May 22, 2017 11:29 pm

Maybe others are too?

It's possible, but less likely than if you have one of the hero problems such as "problems with my USB microphone." That will get hundreds of hits.

Thanks for the clip, but it sounds like it may have originally been a highly compressed and processed dance tune, we can't tell where the music production stops and the distortion begins. Can you point to a clean on-line posting of what you expect it to sound like? iTunes: Artist/Song? YouTube clip?

And one other oddity, there is a little segment of silence to the right on the blue waves. It measures a sound volume of -103dB. That's nearly impossible. Everything about this process has something seriously broken.

Koz
kozikowski
Forum Staff
 
Posts: 37721
Joined: Thu Aug 02, 2007 5:57 pm
Location: Los Angeles
Operating System: OS X 10.9 Mavericks

Next

Return to Mac OS X



Who is online

Users browsing this forum: No registered users and 7 guests