Audacity not opening cleanly in OSX 10.11.1 Beta-with a CLUE

Help for Audacity 2.x.x on Mac OS X.

ImageThis forum is for Audacity 2.x.x on Mac OS X 10.4 and later.
Please state which version of OS X you are using, the exact three-section version of Audacity from Audacity > About Audacity and whether you obtained the .dmg installer or the zip.

Audacity 1.2.x and 1.3.x are obsolete and no longer supported. If you still have those versions, please upgrade at https://www.audacityteam.org/download/.
The old forums for those versions are now closed, but you can still read the archives of the 1.2.x and 1.3.x forums.

Audacity not opening cleanly in OSX 10.11.1 Beta-with a CLUE

Permanent link to this post Posted by tubegeek » Tue Oct 13, 2015 5:16 pm

I am trying to run Audacity 2.1.1 installed from the disk image found here: http://audacityteam.org/download/mac
I am running El Capitan, OS X 10.11.1 Beta (15B30a) on a MacBook.

I install by dragging the Audacity folder to my applications folder as recommended. When I attempt to start Audacity the following pop-up appears:
"The application “Audacity.app” can’t be opened."

I tried right-clicking on the app and selecting "open" from the drop-down menu, same result.

In my Console I do see messages regarding Audacity, which I'll paste below.

Any help interpreting these messages would be much appreciated, thanks! I don't understand them.

I was able to get Audacity to start as follows: I opened the package contents and drilled down to /Applications/Audacity/Audacity.app/Contents/MacOS/ where I found an executable "Audacity" with no ".sh" extension. Double-clicking it opens a Terminal, and subsequently Audacity opens.

I manually added ".sh" to the executable; I got a warning the first time I tried to run it. (I didn't copy/paste so I don't have the exact warning language; it was a warning the app may be incomplete or damaged.) I then changed the executable back to no extension and it opened OK. I made a copy of the executable and then renamed THAT to "Audacity.sh" and tried launching using the application icon in the higher level folder /Applications/Audacity.

THIS OPENED SUCCESSFULLY! I first got the standard warning that the app was DL'ed from the Internet, and I OK'ed it. The app then opened. Second launch no warning.

I was able to test the basic function of recording and playing back audio from the built-in mic OK.

Finally: I noticed that the Get Info window (from OSX Finder) shows Audacity.app as version 2.0.3.0, not 2.1.1. "About Audacity" has 2.1.1.

I hope this info is helpful.....???

UNSUCCESSFUL LAUNCH CONSOLE INFO:

Code: Select all
10/13/15 12:48:08.004 PM com.apple.xpc.launchd[1]: (com.apple.xpc.launchd.oneshot.0x10000033.Audacity.sh[7734]) Could not find and/or execute program specified by service: 2: No such file or directory: /Applications/Audacity/Audacity.app/Contents/MacOS/Audacity.sh

10/13/15 12:48:08.003 PM Finder[553]: spawn_via_launchd() failed, errno=111 label=[0x0-0xa80a80].net.sourceforge.audacity path=/Applications/Audacity/Audacity.app/Contents/MacOS/Audacity.sh flags=1 : LaunchApplicationClient.cp #963 LaunchApplicationWithSpawnViaLaunchD() q=com.apple.root.default-qos

10/13/15 12:48:08.003 PM Finder[553]: spawn_via_launchd() failed, errno=111 label=[0x0-0xa80a80].net.sourceforge.audacity path=/Applications/Audacity/Audacity.app/Contents/MacOS/Audacity.sh flags=1

10/13/15 12:48:37.073 PM com.apple.xpc.launchd[1]: (com.apple.xpc.launchd.oneshot.0x10000034.Audacity.sh[7738]) Could not find and/or execute program specified by service: 2: No such file or directory: /Applications/Audacity/Audacity.app/Contents/MacOS/Audacity.sh

10/13/15 12:48:37.072 PM Finder[553]: spawn_via_launchd() failed, errno=111 label=[0x0-0xa83a83].net.sourceforge.audacity path=/Applications/Audacity/Audacity.app/Contents/MacOS/Audacity.sh flags=1 : LaunchApplicationClient.cp #963 LaunchApplicationWithSpawnViaLaunchD() q=com.apple.root.default-qos

10/13/15 12:48:37.072 PM Finder[553]: spawn_via_launchd() failed, errno=111 label=[0x0-0xa83a83].net.sourceforge.audacity path=/Applications/Audacity/Audacity.app/Contents/MacOS/Audacity.sh flags=1


SUCCESSFUL LAUNCH CONSOLE INFO:
Code: Select all
10/13/15 1:12:50.570 PM Audacity[7816]: WARNING: The Gestalt selector gestaltSystemVersion is returning 10.9.1 instead of 10.11.1. This is not a bug in Gestalt -- it is a documented limitation. Use NSProcessInfo's operatingSystemVersion property to get correct system version number.
Call location:

10/13/15 1:12:50.572 PM Audacity[7816]: 0   CarbonCore                          0x9ce41f1d ___Gestalt_SystemVersion_block_invoke + 135

10/13/15 1:12:50.572 PM Audacity[7816]: 1   libdispatch.dylib                   0x97ed97e7 _dispatch_client_callout + 50

10/13/15 1:12:50.572 PM Audacity[7816]: 2   libdispatch.dylib                   0x97ed96c3 dispatch_once_f + 78

10/13/15 1:12:50.572 PM Audacity[7816]: 3   libdispatch.dylib                   0x97edaf4d dispatch_once + 31

10/13/15 1:12:50.573 PM Audacity[7816]: 4   CarbonCore                          0x9cdbd9e1 _Gestalt_SystemVersion + 1047

10/13/15 1:12:50.573 PM Audacity[7816]: 5   CarbonCore                          0x9cdbd18a Gestalt + 154

10/13/15 1:12:50.573 PM Audacity[7816]: 6   Audacity                            0x00462ae2 _Z14UMAInitToolboxtb + 50

10/13/15 1:12:51.455 PM Audacity[7816]: 13:12:51.454 WARNING:  140: This application, or a library it uses, is using the deprecated Carbon Component Manager for hosting Audio Units. Support for this will be removed in a future release. Also, this makes the host incompatible with version 3 audio units. Please transition to the API's in AudioComponent.h.
tubegeek
 
Posts: 6
Joined: Tue Oct 13, 2015 4:42 pm
Operating System: Please select

Re: Audacity not opening cleanly in OSX 10.11.1 Beta-with a

Permanent link to this post Posted by Gale Andrews » Tue Oct 13, 2015 6:20 pm

Thank you for documenting your experiments.

Had you installed older versions of Audacity before? The known cause for Audacity 2.1.1 not launching is presence of an audacity.cfg settings file from older versions of Audacity. The workaround of modifying or deleting audacity.cfg is described at http://forum.audacityteam.org/viewtopic.php?f=47&t=86508 and near the top of the 2.1.1 Release Notes.

The problem as described above is believed fixed in our source code so should not be a problem in the next 2.1.2 release. It was a problem of writing the "socket" file https://github.com/audacity/audacity/commit/2a6d423.

Yes Audacity is executed by a shell script inside the app bundle. If you rename Audacity.app/Contents/MacOS/Audacity to "Audacity.sh" the script becomes a non-executable text file and Audacity won't launch.

tubegeek wrote:I noticed that the Get Info window (from OSX Finder) shows Audacity.app as version 2.0.3.0, not 2.1.1. "About Audacity" has 2.1.1

I see 2.1.1.0 here.

Let us know if this was the first time you had ever used Audacity. By the way, although it can be useful to experiment with beta versions of operating systems, Audacity has no explicit support for that and I recommend you use the released OS for production work.


Gale
________________________________________FOR INSTANT HELP: (Click on Link below)
* * * * * Tips * * * * * Tutorials * * * * * Quick Start Guide * * * * * Audacity Manual
Gale Andrews
Quality Assurance
 
Posts: 26089
Joined: Fri Jul 27, 2007 12:02 am
Operating System: Windows 10

Re: Audacity not opening cleanly in OSX 10.11.1 Beta-with a

Permanent link to this post Posted by tubegeek » Tue Oct 13, 2015 11:01 pm

Gale Andrews wrote:Thank you for documenting your experiments.


But of course!
Gale Andrews wrote:Had you installed older versions of Audacity before?


Yes. 2.0.3 I think was the previous running version, I don't remember the last OS version I was using it with, I don't use it too frequently. (Don't know why - great program!)

Gale Andrews wrote:
The known cause for Audacity 2.1.1 not launching is presence of an audacity.cfg settings file from older versions of Audacity.


I did see that info in another thread, I had deleted that .cfg file as part of my attempt to get the new version running, but that did not help.

Gale Andrews wrote:The problem as described above is believed fixed in our source code so should not be a problem in the next 2.1.2 release. It was a problem of writing the "socket" file https://github.com/audacity/audacity/commit/2a6d423.



Sweet ;)

Gale Andrews wrote:Yes Audacity is executed by a shell script inside the app bundle. If you rename Audacity.app/Contents/MacOS/Audacity to "Audacity.sh" the script becomes a non-executable text file and Audacity won't launch.

I would have thought that would depend on the file permissions, not the filename extension? FWIW, the Finder ID's the original executable as a "Unix Executable" with Terminal as the default application for opening it, and the copy (.sh extension) as a "Shell Script" with Xcode as the default application to open it.
Gale Andrews wrote:
tubegeek wrote:I noticed that the Get Info window (from OSX Finder) shows Audacity.app as version 2.0.3.0, not 2.1.1. "About Audacity" has 2.1.1

I see 2.1.1.0 here.

See linked screenshots from my installation.
About screen
Welcome Screen
Get Info

I wonder if the Get Info window is stuck with the metadata from the previous installation for some reason....I think that was the last version I had that was working without any weirdness.
Gale Andrews wrote:Let us know if this was the first time you had ever used Audacity.

No, off and on for a while. I usually use SoundStudio for stuff that is simpler and ProTools for stuff that is more complicated. I left my iLok at work so I was trying to get something done that SoundStudio wasn't really cutting it for.
Gale Andrews wrote:By the way, although it can be useful to experiment with beta versions of operating systems, Audacity has no explicit support for that and I recommend you use the released OS for production work.

I couldn't agree more!
tubegeek
 
Posts: 6
Joined: Tue Oct 13, 2015 4:42 pm
Operating System: Please select

Re: Audacity not opening cleanly in OSX 10.11.1 Beta-with a

Permanent link to this post Posted by ohthehugemanatee » Mon Aug 22, 2016 1:50 pm

Bumping this old thread because I have the exact same issue. I'm on OSX 10.11.6 (15G31), and since I updated audacity to 2.1.2 I can't open it anymore. Same error popup, same error 111 in console.log.

After updating (by replacing the folder I had in /Applications) and getting the error message, google showed me a post about deleting ~/Library/Application Support/audacity . That didn't help. After deleting it I reinstalled the application (dragged it to the trash, dragged a fresh version in from the DMG). Didn't help. I tried looking for any old audacity.cfg files kicking around in my homedir with
Code: Select all
find ~ -name 'audacity.cfg'
, and didn't come up with anything.

The good news is that @tubegeek's protocol worked for me - the app opened and operates normally. I also had a peek into the Info.plist file with XCode, and didn't see anything unusual. After quitting out of XCode and closing that version of Audacity I had opened with @tubegeek's instructions... now the application starts from Audacity.app .

Go figure. Hopefully this report will be helpful for the dev team!
ohthehugemanatee
 
Posts: 2
Joined: Thu Oct 27, 2011 2:30 pm
Operating System: Please select

Re: Audacity not opening cleanly in OSX 10.11.1 Beta-with a

Permanent link to this post Posted by Gale Andrews » Tue Aug 23, 2016 1:06 pm

Thanks. Given we can't reproduce the problem, it's only background information, unless we can understand in what way your system is different.

Do you also get tubegeek's issue that Finder's Get Info gives you a different version number than Audacity > About Audacity...?


Gale


ohthehugemanatee wrote:Bumping this old thread because I have the exact same issue. I'm on OSX 10.11.6 (15G31), and since I updated audacity to 2.1.2 I can't open it anymore. Same error popup, same error 111 in console.log.

After updating (by replacing the folder I had in /Applications) and getting the error message, google showed me a post about deleting ~/Library/Application Support/audacity . That didn't help. After deleting it I reinstalled the application (dragged it to the trash, dragged a fresh version in from the DMG). Didn't help. I tried looking for any old audacity.cfg files kicking around in my homedir with
Code: Select all
find ~ -name 'audacity.cfg'
, and didn't come up with anything.

The good news is that @tubegeek's protocol worked for me - the app opened and operates normally. I also had a peek into the Info.plist file with XCode, and didn't see anything unusual. After quitting out of XCode and closing that version of Audacity I had opened with @tubegeek's instructions... now the application starts from Audacity.app .

Go figure. Hopefully this report will be helpful for the dev team!
________________________________________FOR INSTANT HELP: (Click on Link below)
* * * * * Tips * * * * * Tutorials * * * * * Quick Start Guide * * * * * Audacity Manual
Gale Andrews
Quality Assurance
 
Posts: 26089
Joined: Fri Jul 27, 2007 12:02 am
Operating System: Windows 10

Re: Audacity not opening cleanly in OSX 10.11.1 Beta-with a

Permanent link to this post Posted by rsholmes » Mon Sep 26, 2016 2:22 am

I also downloaded Audacity 2.1.2.0 and could not open it. I first tried deleting the offending line in ~/Library/Application Support/audacity/audacity.cfg, and then tried deleting the .cfg file altogether. Audacity still wouldn't open. Error dialog was "The application “Audacity” can’t be opened." Console log showed:

9/25/16 9:44:51.829 PM lsd[296]: LaunchServices: Could not store lsd-identifiers file at /private/var/db/lsd/com.apple.lsdschemes.plist
9/25/16 9:44:51.837 PM lsd[296]: LaunchServices: Could not store lsd-identifiers file at /private/var/db/lsd/com.apple.lsdschemes.plist
9/25/16 9:44:51.855 PM com.apple.xpc.launchd[1]: (com.apple.xpc.launchd.oneshot.0x10000013.Audacity.sh[19262]) Could not find and/or execute program specified by service: 2: No such file or directory: /Applications/Audacity/Audacity.app/Contents/MacOS/Audacity.sh
9/25/16 9:44:51.855 PM Finder[330]: spawn_via_launchd() failed, errno=111 label=[0x0-0x692692].net.sourceforge.audacity path=/Applications/Audacity/Audacity.app/Contents/MacOS/Audacity.sh flags=1 : LaunchApplicationClient.cp #963 LaunchApplicationWithSpawnViaLaunchD() q=com.apple.root.default-qos
9/25/16 9:44:51.855 PM Finder[330]: spawn_via_launchd() failed, errno=111 label=[0x0-0x692692].net.sourceforge.audacity path=/Applications/Audacity/Audacity.app/Contents/MacOS/Audacity.sh flags=1
9/25/16 9:44:51.865 PM lsd[296]: LaunchServices: Could not store lsd-identifiers file at /private/var/db/lsd/com.apple.lsdschemes.plist

Then I tried a variant of tubegeek's hack: I created an alias to /Applications/Audacity/Audacity.app/Contents/MacOS/Audacity and named it Audacity.sh. Then I was able to open the application.

I'm using Mac OS 10.11.6.
rsholmes
 
Posts: 1
Joined: Mon Sep 26, 2016 1:39 am
Operating System: OS X 10.11 El Capitan or later (macOS)

Re: Audacity not opening cleanly in OSX 10.11.1 Beta-with a

Permanent link to this post Posted by Gale Andrews » Mon Sep 26, 2016 1:15 pm

rsholmes wrote:I also downloaded Audacity 2.1.2.0 and could not open it. I first tried deleting the offending line in ~/Library/Application Support/audacity/audacity.cfg, and then tried deleting the .cfg file altogether. Audacity still wouldn't open. Error dialog was "The application “Audacity” can’t be opened."

That error message is generated by the Mac, not by Audacity. How exactly are you "opening" Audacity?

We can't fix it if we can't reproduce it on our own machines running 10.11.6 or understand in what way your machine is different. Are your running as a guest or with low privileges?

Do you also get tubegeek's issue that Finder's Get Info gives you a different version number than Audacity > About Audacity...? If yes, the problem could be messed up plist files. Have you tried "repairing" the disk in Disk Utility?


Gale

Console log showed:

9/25/16 9:44:51.829 PM lsd[296]: LaunchServices: Could not store lsd-identifiers file at /private/var/db/lsd/com.apple.lsdschemes.plist
9/25/16 9:44:51.837 PM lsd[296]: LaunchServices: Could not store lsd-identifiers file at /private/var/db/lsd/com.apple.lsdschemes.plist
9/25/16 9:44:51.855 PM com.apple.xpc.launchd[1]: (com.apple.xpc.launchd.oneshot.0x10000013.Audacity.sh[19262]) Could not find and/or execute program specified by service: 2: No such file or directory: /Applications/Audacity/Audacity.app/Contents/MacOS/Audacity.sh
9/25/16 9:44:51.855 PM Finder[330]: spawn_via_launchd() failed, errno=111 label=[0x0-0x692692].net.sourceforge.audacity path=/Applications/Audacity/Audacity.app/Contents/MacOS/Audacity.sh flags=1 : LaunchApplicationClient.cp #963 LaunchApplicationWithSpawnViaLaunchD() q=com.apple.root.default-qos
9/25/16 9:44:51.855 PM Finder[330]: spawn_via_launchd() failed, errno=111 label=[0x0-0x692692].net.sourceforge.audacity path=/Applications/Audacity/Audacity.app/Contents/MacOS/Audacity.sh flags=1
9/25/16 9:44:51.865 PM lsd[296]: LaunchServices: Could not store lsd-identifiers file at /private/var/db/lsd/com.apple.lsdschemes.plist

Then I tried a variant of tubegeek's hack: I created an alias to /Applications/Audacity/Audacity.app/Contents/MacOS/Audacity and named it Audacity.sh. Then I was able to open the application.

I'm using Mac OS 10.11.6.
________________________________________FOR INSTANT HELP: (Click on Link below)
* * * * * Tips * * * * * Tutorials * * * * * Quick Start Guide * * * * * Audacity Manual
Gale Andrews
Quality Assurance
 
Posts: 26089
Joined: Fri Jul 27, 2007 12:02 am
Operating System: Windows 10

Re: Audacity not opening cleanly in OSX 10.11.1 Beta-with a

Permanent link to this post Posted by cyrano » Mon Sep 26, 2016 2:03 pm

From memory and FWIW:

This seems to happen to people who upgraded from Mavericks to EC. The reason seems to be that either the "lsd" folder in

/private/var/db/

is missing, or you may have a corrupted Launch Services database.

To reset the database:

Code: Select all
/System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user ; killall Dock


Restart the mac.

This launch services stuff gets cached at startup, so debugging trough changing the plist with a text editor won't work, unless you restart every time.
cyrano
 
Posts: 1283
Joined: Fri Apr 17, 2015 11:54 pm
Operating System: OS X 10.9 Mavericks

Re: Audacity not opening cleanly in OSX 10.11.1 Beta-with a

Permanent link to this post Posted by Gale Andrews » Mon Sep 26, 2016 3:01 pm

cyrano wrote:From memory and FWIW:

This seems to happen to people who upgraded from Mavericks to EC. The reason seems to be that either the "lsd" folder in

/private/var/db/

is missing, or you may have a corrupted Launch Services database.

Thanks, cyrano. So you think this might be a problem if you upgraded from Mavericks direct to El Capitan (or Sierra), bypassing Yosemite?

I recall now that I've used that command to rebuild the launch services database when the Open with menu gets cluttered with multiple versions of Audacity and other applications, or hangs fetching the list.


Gale
________________________________________FOR INSTANT HELP: (Click on Link below)
* * * * * Tips * * * * * Tutorials * * * * * Quick Start Guide * * * * * Audacity Manual
Gale Andrews
Quality Assurance
 
Posts: 26089
Joined: Fri Jul 27, 2007 12:02 am
Operating System: Windows 10

Re: Audacity not opening cleanly in OSX 10.11.1 Beta-with a

Permanent link to this post Posted by cyrano » Mon Sep 26, 2016 7:24 pm

Gale Andrews wrote:
cyrano wrote:From memory and FWIW:

This seems to happen to people who upgraded from Mavericks to EC. The reason seems to be that either the "lsd" folder in

/private/var/db/

is missing, or you may have a corrupted Launch Services database.

Thanks, cyrano. So you think this might be a problem if you upgraded from Mavericks direct to El Capitan (or Sierra), bypassing Yosemite?


I only had that command saved - no other notes. That fixed it for one user with Filemaker Pro 15. So I googled a bit and then remembered his Mac was upgraded from Mav to EC, which seemed to be true for other cases I found. But other workarounds seem to work too, like the one Tubegeek found.

And these cases were with a lot of other apps too, so it's not Audacity, but something in EC.

I recall now that I've used that command to rebuild the launch services database when the Open with menu gets cluttered with multiple versions of Audacity and other applications, or hangs fetching the list.


I don't really understand what changed with EC, as I don't use EC atm. My EC machine is still in need of a new SATA cable. And I'm too lazy to set up an external disk :D

I need a newer mac to run Sierra anyways, so I'd like to find a new Macbook Pro SATA cable first. Unfortunately, all the usual suppliers are out of stock. These break an awful lot, if you ask me. :cry:
cyrano
 
Posts: 1283
Joined: Fri Apr 17, 2015 11:54 pm
Operating System: OS X 10.9 Mavericks

Next

Return to Mac OS X



Who is online

Users browsing this forum: Bing [Bot] and 5 guests