Adjustable Fade "Error" error.

Help for Audacity 2.x.x on Windows.

ImageThis forum is for Audacity 2.x.x on Windows.
Please state which version of Windows you are using,
and the exact three-section version number of Audacity from "Help menu > About Audacity".


Audacity 1.2.x and 1.3.x are obsolete and no longer supported. If you still have those versions, please upgrade at https://www.audacityteam.org/download/.
The old forums for those versions are now closed, but you can still read the archives of the 1.2.x and 1.3.x forums.

Adjustable Fade "Error" error.

Permanent link to this post Posted by andy2619 » Thu Jan 11, 2018 5:57 pm

Hello,

Running Audacity 2.2.1 (program build Dec 6 2017) on Windows 10 64-bit version 1607.

I am trying to use the Adjustable Fade effect on a sound clip I have, and clicking either the Preview or OK button will result in an "Error" message box. Have completely uninstalled Audacity and reinstalled with no avail as well as deleting the AppData folders and such created by audacity. Any recommendations?
Attachments
error.png
Screenshot
error.png (15.63 KiB) Viewed 294 times
andy2619
 
Posts: 7
Joined: Thu Jan 11, 2018 5:52 pm
Operating System: Windows 10

Re: Adjustable Fade "Error" error.

Permanent link to this post Posted by steve » Thu Jan 11, 2018 6:36 pm

Does the problem happen with just that one project, or all projects?
How big is the project and how long is the selected audio?
Do the "High Pass Filter" and "Low Pass Filter" effects work?
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 46541
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: Adjustable Fade "Error" error.

Permanent link to this post Posted by andy2619 » Thu Jan 11, 2018 7:05 pm

This problem happens with all projects and different music files, this particular one being 1:30 in length approximately 6.6kb in size. The selected audio is about 3 seconds long.

High pass and low pass filters also do not work upon troubleshooting. I receive errors of "Nyquist returned the value: x" depending on the rolloff chosen.
andy2619
 
Posts: 7
Joined: Thu Jan 11, 2018 5:52 pm
Operating System: Windows 10

Re: Adjustable Fade "Error" error.

Permanent link to this post Posted by steve » Thu Jan 11, 2018 8:00 pm

Take a look in "Help > Diagnostics > Show Log".

There is usually a load of stuff related to loading FFmpeg at the start, so to make things clearer I'd suggest that you:
1) Launch Audacity
2) Open the Log
3) Clear the log
4) Attempt to run any Nyquist effect (such as Adjustable Fade or High-Pass Filter).

I would expect there to be some error / debug information in the log. If there is, please post it with your reply.
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 46541
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: Adjustable Fade "Error" error.

Permanent link to this post Posted by andy2619 » Thu Jan 11, 2018 8:38 pm

HI Steve

Here are the results of clearing the log and reattempting the Adjustable Fade:

14:37:32: Audacity 2.2.1
Log Cleared.
14:38:01: 'Adjustable Fade' returned:
error: unbound function - MULT
andy2619
 
Posts: 7
Joined: Thu Jan 11, 2018 5:52 pm
Operating System: Windows 10

Re: Adjustable Fade "Error" error.

Permanent link to this post Posted by steve » Thu Jan 11, 2018 9:10 pm

What is the system language of your computer?
What is the exact location of the "audacity.exe" file?

Please also restart Audacity, and then open the Log, and post the contents.

The problem is that Nyquist is unable to find some of its files. My suspicion is that it is because the path includes Unicode characters, but Nyquist only understands ASCII.
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 46541
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: Adjustable Fade "Error" error.

Permanent link to this post Posted by andy2619 » Fri Jan 12, 2018 11:13 pm

Hi Steve

My system language is English and the location of Audacity.exe is C:\Program Files (x86)\Audacity

Here is the contents of the log after restart:
Code: Select all
17:11:20: Audacity 2.2.1
17:11:20: Trying to load FFmpeg libraries...
17:11:20: mLibAVFormatPath ('C:\Program Files (x86)\Audacity\ffmpeg-win-2.2.2\avformat-55.dll') is not empty. Loading from it.
17:11:20: Looking up PATH environment variable...
17:11:20: PATH = 'C:\ProgramData\Oracle\Java\javapath;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;C:\WINDOWS\System32\WindowsPowerShell\v1.0\;C:\Program Files\OpenVPN\bin;C:\Program Files (x86)\Windows Kits\8.1\Windows Performance Toolkit\;C:\Program Files\Microsoft SQL Server\110\Tools\Binn\;C:\Program Files (x86)\Microsoft SDKs\TypeScript\1.0\;C:\Program Files\Microsoft SQL Server\120\Tools\Binn\;C:\Program Files (x86)\Microsoft SQL Server\120\Tools\Binn\ManagementStudio\;C:\Program Files (x86)\Microsoft SQL Server\120\Tools\Binn\;C:\Program Files (x86)\Microsoft Visual Studio 12.0\Common7\IDE\PrivateAssemblies\;C:\Program Files (x86)\Microsoft SQL Server\120\DTS\Binn\;C:\Program Files (x86)\Microsoft Dynamics AX\60\Client\Bin\;C:\Program Files\Microsoft SQL Server\Client SDK\ODBC\110\Tools\Binn\;C:\Program Files\Microsoft SQL Server\120\DTS\Binn\;C:\Program Files\Microsoft Dynamics AX\60\BusinessConnector\Bin\;C:\Program Files (x86)\Microsoft Team Foundation Server 2012 Power Tools\Best Practices Analyzer\;C:\Users\andy\AppData\Local\Microsoft\WindowsApps;C:\Program Files\Microsoft Dynamics AX\60\ManagementUtilities'
17:11:20: Checking that 'C:\Program Files (x86)\Audacity\ffmpeg-win-2.2.2' is in PATH...
17:11:20: Warning: FFmpeg directory 'C:\Program Files (x86)\Audacity\ffmpeg-win-2.2.2' is not in PATH.
17:11:20: Temporarily prepending ';C:\Program Files (x86)\Audacity\ffmpeg-win-2.2.2' to PATH...
17:11:20: Checking for monolithic avformat from 'C:\Program Files (x86)\Audacity\ffmpeg-win-2.2.2\avformat-55.dll'.
17:11:20: Error: Couldn't find symbol 'avutil_version' in a dynamic library (error 127: the specified procedure could not be found.)
17:11:20: Error: Couldn't find symbol 'avcodec_version' in a dynamic library (error 127: the specified procedure could not be found.)
17:11:20: avformat not monolithic
17:11:20: Loading avutil from 'avutil-52.dll'.
17:11:20: Loading avcodec from 'avcodec-55.dll'.
17:11:20: Loading avformat from 'C:\Program Files (x86)\Audacity\ffmpeg-win-2.2.2\avformat-55.dll'.
17:11:20: Returning PATH to previous setting...
17:11:20: Actual avutil path C:\Program Files (x86)\Audacity\ffmpeg-win-2.2.2\avutil-52.dll
17:11:20: Actual avcodec path C:\Program Files (x86)\Audacity\ffmpeg-win-2.2.2\avcodec-55.dll
17:11:20: Actual avformat path C:\Program Files (x86)\Audacity\ffmpeg-win-2.2.2\avformat-55.dll
17:11:20: Importing symbols...
17:11:20: All symbols loaded successfully. Initializing the library.
17:11:20: Retrieving FFmpeg library version numbers:
17:11:20:    AVCodec version 0x373466 - 55.52.102 (built against 0x373466 - 55.52.102)
17:11:20:    AVFormat version 0x372164 - 55.33.100 (built against 0x372164 - 55.33.100)
17:11:20:    AVUtil version 0x344264 - 52.66.100 (built against 0x344264 - 52.66.100)
17:11:20: FFmpeg libraries loaded successfully.
Last edited by steve on Sat Jan 13, 2018 12:06 pm, edited 1 time in total.
Reason: code tags added
andy2619
 
Posts: 7
Joined: Thu Jan 11, 2018 5:52 pm
Operating System: Windows 10

Re: Adjustable Fade "Error" error.

Permanent link to this post Posted by steve » Sat Jan 13, 2018 12:23 pm

This is puzzling. I've seen this problem once before, but that was with Audacity running from a folder having Cyrillic characters in its name.
For some reason, some required Nyquist files are not being found, but I don't yet see any reason for that.

In the Effects menu, do you have the "Nyquist Prompt" effect listed?
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 46541
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: Adjustable Fade "Error" error.

Permanent link to this post Posted by andy2619 » Mon Jan 15, 2018 4:47 pm

Hi Steve

Yep I have Nyquist Prompt in my menu.
andy2619
 
Posts: 7
Joined: Thu Jan 11, 2018 5:52 pm
Operating System: Windows 10

Re: Adjustable Fade "Error" error.

Permanent link to this post Posted by steve » Mon Jan 15, 2018 7:17 pm

Look in C:\Program Files (x86)\Audacity
There should be a folder called "Nyquist". Is it there?
In that "Nyquist" folder should be 28 ".lsp" files and a folder called "rawwaves". Are they there?
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 46541
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Next

Return to Windows



Who is online

Users browsing this forum: No registered users and 10 guests