A2.2.1 Win10: "Amplifiy" Validation error

Help for Audacity 2.x.x on Windows.

ImageThis forum is for Audacity 2.x.x on Windows.
Please state which version of Windows you are using,
and the exact three-section version of Audacity from "Help menu > About Audacity".


Audacity 1.2.x and 1.3.x are obsolete and no longer supported. If you still have those versions, please upgrade at https://www.audacityteam.org/download/.
The old forums for those versions are now closed, but you can still read the archives of the 1.2.x and 1.3.x forums.

A2.2.1 Win10: "Amplifiy" Validation error

Permanent link to this post Posted by jbeale » Sat Dec 30, 2017 11:55 pm

Audacity 2.2.1 on Windows 10. If I select a near-silent segment (just low-level noise around -80 dB) and do Effect/Amplify, I get
"Validation error : Value not in range: -130.767 to -30.767"

Amplify would always work on signals of any level in the older version I used until today (I think it was 2.0.4). This problem only occurs on very quiet signals. "Normalize" does work, however.

I liked "Amplify" because it would tell me how many dB down the signal was. I have since discovered "ACX Check" which provides even more data, but I think the Amplify effect should be fixed.
jbeale
 
Posts: 1
Joined: Sat Dec 30, 2017 11:46 pm
Operating System: Windows 10

Re: A2.2.1 Win10: "Amplifiy" Validation error

Permanent link to this post Posted by waxcylinder » Sun Dec 31, 2017 5:14 pm

I cannot reproduce this on W10 even with incredibly low signal levels throughout.

The only way I can get a wobbly is to have a track or selection of pure silence and try to amplify that - for which I need to check the Allow clipping.

What I get then is the error message: Validation Error: Value Overflow

Now that may well be accurate - but it certainly isn't very informative to your average user - I would expevct something like Can't Amplify Silence.

If you can Export some small sample of your low signal level that fails with the error you report, as a WAV file anp post it here - then I can try testing that on my machines (I have a Macbook Pro as well for QA testing)

Thanks,
WC
________________________________________FOR INSTANT HELP: (Click on Link below)
* * * * * FAQ * * * * * Tutorials * * * * * Audacity Manual * * * * * Audacity Wiki * * * * *
waxcylinder
Forum Staff
 
Posts: 9132
Joined: Tue Jul 31, 2007 11:03 am
Location: Manchester, UK
Operating System: Windows 10

Re: A2.2.1 Win10: "Amplifiy" Validation error

Permanent link to this post Posted by steve » Sun Dec 31, 2017 5:55 pm

waxcylinder wrote:I cannot reproduce this on W10 even with incredibly low signal levels throughout.

Possibly because you are using the current development code, or you just happen to have selected audio that has a peak level that rounds the right way.

jbeale wrote:I get
"Validation error : Value not in range: -130.767 to -30.767"

This was a bug that appeared a couple of years ago due to improved input validation. It was fixed soon after it was noticed, but then broke again and no-one noticed until Peter spotted the problem last August. I fixed it again earlier this month (bug 963), so it will be fixed in the next release.
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 45676
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu


Return to Windows



Who is online

Users browsing this forum: Google [Bot], Trebor and 14 guests