Page 1 of 1

Equalization, selection problems

Permanent link to this postPosted: Thu Dec 07, 2017 3:20 am
Posted by fas42
Had to revert to old version of Audacity, going back from 2.2.0 - bugs/changes in behaviour in 2.2 too troublesome. On Windows 8.1,

* Create an equalization curve using points; try applying it again - doesn't work, curve is lost
* Selection toolbar too erratic, can't adjust numbers to fine tune selection lenght, etc - as was always possible before

Re: Equalization, selection problems

Permanent link to this postPosted: Sat Dec 09, 2017 2:32 am
Posted by fas42
More info ... downloaded 2.2.1, the selection mechanism seems better; will investigate more.

The Equalization effect still has bug; have determined that brickwalling the cut off is the issue. IOW, in the Draw mode, dragging one point to as as close as possible to another, say underneath, causes the latter's position to be lost - this wasn't an issue in 2.1.

Re: Equalization, selection problems

Permanent link to this postPosted: Sat Dec 09, 2017 4:43 pm
Posted by waxcylinder
This sounds like this known (and logged) bug:
"Equalization: control points can disappear when switching between log and linear if the points are at the same frequency"
https://bugzilla.audacityteam.org/show_bug.cgi?id=1750

WC

Re: Equalization, selection problems

Permanent link to this postPosted: Sun Dec 10, 2017 10:06 pm
Posted by fas42
Okay, the bug has been around, but what triggers it has altered. Prior to 2.2 I've never seen the control points disappear adjusting for sharp cutoff in Draw mode - the equalisation always works as requested in the first instance, but the memory of the setting is lost as soon as the window is closed.

Re: Equalization, selection problems

Permanent link to this postPosted: Sun Dec 10, 2017 10:52 pm
Posted by fas42
Getting back to the selection peculiarities, there definitely seems to be changes here: I quite often pad the beginning of a track with a tiny silence, for alignment purposes, and this is not behaving in an intuitive manner, as before. Specifically, if I add samples at the very beginning, I have a split, and I can't join the boundaries - this is workaround territory, which I never had to worry about before.

Re: Equalization, selection problems

Permanent link to this postPosted: Sun Dec 10, 2017 10:56 pm
Posted by fas42
And noting that sometimes I get a split, and sometimes not, when inserting a silence - there is a consistency of behaviour issue here.

Also, the precision has been lost. Trying to pad with samples of silence, the number needed to get alignment is hit and miss - is it 15, or 16, say? Never had this problem before.

Re: Equalization, selection problems

Permanent link to this postPosted: Mon Dec 11, 2017 12:58 am
Posted by fas42
Another selection issue, in 2.2.1. Multiple tracks, made the Selection Toolbar floating; altered the Project Rate in that toolbar, then attempted to focus on another track than the selected one, interface didn't respond. Reversed the change of Project Rate, and that allowed track selection to work again.