I don't want to record external sounds

Help for Audacity 2.x.x on Windows.

ImageThis forum is for Audacity 2.x.x on Windows.

  • Please state which version of Windows you are using, the exact three-section version of Audacity from "Help menu > About Audacity".

  • Audacity 1.2.x and 1.3.x are obsolete and no longer supported. If you still have those versions, please upgrade at https://www.audacityteam.org/download/.
    The old forums for those versions are now closed, but you can still read the archives of the 1.2.x and 1.3.x forums.

Suddenly, Audacity is not working right

Permanent link to this post Posted by nelsonkane » Wed Nov 29, 2017 12:20 am

It was working fine for a couple of years.
I want it to record music sounds that I make online, without recording any sounds going on in my room.
I uninstalled it, and installed a new version, but I still have the same problem.

It sounds like it's recording from the external microphone, not internally like I want it to.
Also, the playback is kind of in stereo: it sounds like a duplicate singing at the same time, but not really at the same time. It sounds bad.

Any help would be appreciated! :)
:D
nelsonkane
 
Posts: 7
Joined: Wed Nov 29, 2017 12:17 am
Operating System: Windows 10

I don't want to record external sounds

Permanent link to this post Posted by nelsonkane » Wed Nov 29, 2017 1:18 am

I'm using Audacity 2.2.0 and Windows Chrome 10.

How do I adjust the controls so that it can record music from my computer without recording any sounds taking
place outside of my computer, such as the AC, dog barking, etc. Thanks!
Last edited by steve on Wed Nov 29, 2017 2:16 am, edited 1 time in total.
Reason: Topics merged
nelsonkane
 
Posts: 7
Joined: Wed Nov 29, 2017 12:17 am
Operating System: Windows 10

Re: I don't want to record external sounds

Permanent link to this post Posted by kozikowski » Wed Nov 29, 2017 1:23 am

kozikowski
Forum Staff
 
Posts: 38499
Joined: Thu Aug 02, 2007 5:57 pm
Location: Los Angeles
Operating System: OS X 10.9 Mavericks

Re: I don't want to record external sounds

Permanent link to this post Posted by nelsonkane » Wed Nov 29, 2017 2:14 am

Not a simple thing to resolve. I'll give it a try.

It says that first, I need to do these steps. How would I know if I have the latest correct audio drivers meant for my version of Windows?

"If you do not see Stereo Mix or similar:
Make sure you have the latest correct audio drivers meant for your version of Windows
Go to the Windows Control Panel to see if stereo mix can be enabled
On Windows, choose the Windows WASAPI loopback recording method instead."[/color] :)
Last edited by steve on Wed Nov 29, 2017 2:17 am, edited 1 time in total.
Reason: Remove broken BBCode tags
nelsonkane
 
Posts: 7
Joined: Wed Nov 29, 2017 12:17 am
Operating System: Windows 10

Re: I don't want to record external sounds

Permanent link to this post Posted by steve » Wed Nov 29, 2017 2:23 am

For all modern versions of Windows, the best way to record sounds that are playing on the computer (and not from the microphone) is to use the "WASAPI loopback" method described here: http://manual.audacityteam.org/man/tuto ... ndows.html
(This method does not require the sound card drivers to have a "Stereo Mix" option)

If you still get room sounds recorded when using WASAPI loopback, open the Windows Sound Control Panel and find the recording device that corresponds to the microphone, then in its settings, turn off "Listen to this device" (it 'should' be off by default).
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 45396
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: I don't want to record external sounds

Permanent link to this post Posted by nelsonkane » Wed Nov 29, 2017 2:25 am

Okay, I did this, but it is only recording fragments of what is being played.
I think it's still recording just external sounds.

"If you do not see Stereo Mix or similar:
Make sure you have the latest correct audio drivers meant for your version of Windows
Go to the Windows Control Panel to see if stereo mix can be enabled"==================================I was able to enable it. But it did not help. :)


It says to do this: "On Windows, choose the Windows WASAPI loopback recording method instead"
I've never heard of a WASAPI. :)
nelsonkane
 
Posts: 7
Joined: Wed Nov 29, 2017 12:17 am
Operating System: Windows 10

Re: I don't want to record external sounds

Permanent link to this post Posted by nelsonkane » Wed Nov 29, 2017 2:32 am

Okay, I did it. I found the WASAPI, but I noticed that when I do that, Audacity automatically
moves the "recording" level to the highest level, which is why the playback sounds fuzzy.

The recording button will not move unless I delete what I recorded and change WASAPI back to what it was before.
nelsonkane
 
Posts: 7
Joined: Wed Nov 29, 2017 12:17 am
Operating System: Windows 10

Re: I don't want to record external sounds

Permanent link to this post Posted by steve » Wed Nov 29, 2017 2:39 am

nelsonkane wrote:I think it's still recording just external sounds.

Is it or isn't it?
Try making a loud sound near the computer microphone while recording.

nelsonkane wrote:I've never heard of a WASAPI. :)

It was a new feature in Windows Vista, and has been part the Windows sound system ever since. https://msdn.microsoft.com/en-us/librar ... 55(v=vs.85).aspx
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 45396
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: I don't want to record external sounds

Permanent link to this post Posted by steve » Wed Nov 29, 2017 2:41 am

nelsonkane wrote:The recording button will not move unless I delete what I recorded and change WASAPI back to what it was before.

I've no idea what that means.
Which "recording button" are you referring to?
What are you "changing back" to what?
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 45396
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: I don't want to record external sounds

Permanent link to this post Posted by steve » Wed Nov 29, 2017 2:46 am

Note that when recording what's playing on your computer, the recording level depends on the playback level. The "loopback" is effectively a connection from the output of the sound card to the input, so the louder the sound at the output, the higher the recording level will be.

It is possible that your computer sound system is not behaving properly, but you will need to try to be very clear about what is happening for us to understand what is happening - we can't see your computer, we can only work with what you tell us.
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 45396
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu


Return to Windows



Who is online

Users browsing this forum: No registered users and 19 guests