Can't turn off Sound Activated Recording

Help for Audacity 2.x.x on Windows.

ImageThis forum is for Audacity 2.x.x on Windows.

  • Please state which version of Windows you are using, the exact three-section version of Audacity from "Help menu > About Audacity".

  • Audacity 1.2.x and 1.3.x are obsolete and no longer supported. If you still have those versions, please upgrade at https://www.audacityteam.org/download/.
    The old forums for those versions are now closed, but you can still read the archives of the 1.2.x and 1.3.x forums.

Can't turn off Sound Activated Recording

Permanent link to this post Posted by cmaple » Sun Nov 19, 2017 10:11 pm

I'm running Audacity 2.1.0 on Windows 10. All works except I cannot turn off sound activated recording. I did disable it in the UI at Edit > Preferences > Recording but still it acts as if it is on. I set the activation level to -60 hoping that would turn it on all the time but that does not help. I'm having trouble with Audacity missing the beginning of some clips so I am modifying the Latency and the Latency correction hoping that will help. But really what I want is to manually start and stop recording and be rid of this functionality.
Attachments
SoundActivated.png
UI for recording options
SoundActivated.png (41.14 KiB) Viewed 185 times
cmaple
 
Posts: 3
Joined: Sun Nov 19, 2017 9:56 pm
Operating System: Windows 10

Re: Can't turn off Sound Activated Recording

Permanent link to this post Posted by steve » Sun Nov 19, 2017 11:29 pm

Sound Activated Recording is disabled when the "Sound Activated Recording" checkbox is not ticked (as in your screenshot).

Please describe precisely what is happening. It sounds as if it is not what you think, because if those are your settings, then Sound Activated Recording is already turned off.
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 45396
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: Can't turn off Sound Activated Recording

Permanent link to this post Posted by kozikowski » Sun Nov 19, 2017 11:44 pm

That and what are you doing? What's the job? What are you recording?
still it acts as if it is on.

You can have a broken condition that makes it appear as if it's on.

Audacity gets its sound from Windows, not the microphone or other device. If you have poor connections or ratty driver software, you can get some of the same symptoms.

I know this is a standing joke, but have you restarted your machine? I mean really restart it—make Windows start over. Hold Shift and Shutdown. It could take a bit longer to actually shut down this way because Windows shuts down and halts a lot more things.

When the machine comes back up, don't start any other software. Does Audacity still do that?

Koz
kozikowski
Forum Staff
 
Posts: 38499
Joined: Thu Aug 02, 2007 5:57 pm
Location: Los Angeles
Operating System: OS X 10.9 Mavericks

Re: Can't turn off Sound Activated Recording

Permanent link to this post Posted by cmaple » Mon Nov 20, 2017 3:31 am

I'm recording a streaming radio station. I can control when the stream starts playing in an Internet Explorer window and I've been noticing that the beginning of the clip sometimes gets clipped. My procedure is to first start Audacity recording and then start the streaming station playback.

I say it appears as if sound activated recording is turned on because when I put it in record mode the waveform window is paused and no recording is occurring. If sound activated recording was turned off I would expect that the waveform display should be displaying a flatline and scrolling to the right recording silence. As soon as I start the streaming station Audacity starts displaying the waveform and scrolling occurs.

I just tried upgrading to the latest 2.2 version to see if there was a bug fixed but the same behavior occurs in the new version. The described behavior has been occurring for 6 months and the system has been hard booted several times. Thanks for your troubleshooting ideas!
cmaple
 
Posts: 3
Joined: Sun Nov 19, 2017 9:56 pm
Operating System: Windows 10

Re: Can't turn off Sound Activated Recording

Permanent link to this post Posted by steve » Mon Nov 20, 2017 10:32 am

cmaple wrote:I'm recording a streaming radio station.

You missed out an important part, but I think I can guess: "I'm recording a streaming radio station with WASAPI loopback."
Am I right?

WASAPI is different from the older WDM / directsound systems in that it runs "on demand". Audio streams only exist when there is audio data.
The good news is that, when set up correctly, it allows very high quality "bit-for-bit" copying of an audio stream. However, as the copy is bit-for-bit, when there is no audio playing, there is nothing to record, so Audacity records (literally) nothing. "Silence" is not "nothing". "Silence" is a stream of zero amplitude samples. "Nothing" is no samples.

Personally I find this behaviour convenient. I don't need to worry about cueing up the Internet audio, then starting the recording and un-pausing the Internet audio as fast as possible. I can just set Audacity to record, (Audacity waits for an audio stream), then start playback in my web browser and Audacity starts recording immediately.

Some users find the behaviour disconcerting and find ways to 'fool the system' so that Audacity records silence (or near silence) when the browser player is not playing. To do that, you need to find a way to ensure that there is always an active audio stream. I've not really investigated how to do that because I prefer to have the most accurate (bit-for-bit) copy possible. Nevertheless, one possible way is to turn on "listen to this device" for an unused audio device (in the Windows Sound Control Panel) so that there is an "always on" silent audio stream. The downside is that you then don't get a bit-for-bit copy, but a mix of the stream that you want to record, plus the "silent stream".

Note that when recording from WASAPI loopback. the sample rate for the device in the Windows Sound Control Panel should be set the same as the sample rate that you are recording at in Audacity (by default that's 44100 Hz).
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 45396
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: Can't turn off Sound Activated Recording

Permanent link to this post Posted by cmaple » Mon Nov 20, 2017 8:44 pm

Thanks for the explanation Steve, it was very helpful understanding what is going on. I'm glad to hear that this is not an Audacity issue.

I guess if I increase the latency correction there's a chance it might help with the clipping I'm noticing at the beginning of the recording? WASAPI in my experience seems to inject around 1 sec of silence at the beginning of the recording but the audio clipping I've been noticing occurs after the silence so perhaps increased latency is not going to help out. Is my understanding about the latency settings correct in that increasing the 'Audio to buffer' buffers more audio before playing or displaying on the waveform graph? How does the 'Latency correction' affect the recording? Which of these would best help (if any) my clipping problem?
cmaple
 
Posts: 3
Joined: Sun Nov 19, 2017 9:56 pm
Operating System: Windows 10

Re: Can't turn off Sound Activated Recording

Permanent link to this post Posted by steve » Mon Nov 20, 2017 9:04 pm

cmaple wrote:I guess if I increase the latency correction there's a chance it might help with the clipping I'm noticing at the beginning of the recording?

There is a fairly common issue when using WASAPI loopback, that if the sample rate for the device in the Windows Sound Control Panel does not match the sample rate that Audacity is recording at, a small "gap" (silence) occurs near the beginning of the recording. Your description sounds like a severe example of that problem.

What I'd suggest is that you set the recording preferences (http://manual.audacityteam.org/man/reco ... ences.html) and the Quality preferences (http://manual.audacityteam.org/man/qual ... ences.html) back to their default settings.
Then in the Windows Sound Control Panel, find the sample rate setting for the device that you are using, and set it to 44100 (it's probably set to 48000).
Then try a test recording.

Good luck - let us know what happens.
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 45396
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu


Return to Windows



Who is online

Users browsing this forum: Bing [Bot] and 10 guests