Recorded streaming latency issue

Help for Audacity 2.x.x on Windows.

ImageThis forum is for Audacity 2.x.x on Windows.

  • Please state which version of Windows you are using, the exact three-section version of Audacity from Help > About Audacity and whether you obtained the .exe installer or the zip.

  • Audacity 1.2.x and 1.3.x are obsolete and no longer supported. If you still have those versions, please upgrade at https://www.audacityteam.org/download/.
    The old forums for those versions are now closed, but you can still read the archives of the 1.2.x and 1.3.x forums.

Recorded streaming latency issue

Permanent link to this post Posted by audino » Sun Jul 16, 2017 1:40 pm

Hello,

I'm recording a sample streaming and it resulted with latency, I think this is the correct way to describe it.
I'm attaching the sample.

The system:
Windows 7 Ultimate 64bit.
Audacity 2.1.3 - exe installer.

Could you please help me understand what is the problem?
Attachments
Sample.mp3
(709.19 KiB) Downloaded 4 times
audino
 
Posts: 85
Joined: Fri Jun 15, 2012 8:18 am
Operating System: Windows 7

Re: Recorded streaming latency issue

Permanent link to this post Posted by steve » Sun Jul 16, 2017 5:39 pm

audino wrote:I'm recording a sample streaming and it resulted with latency,

I think "latency" may be the wrong word.
Try describing the problem in more words - is it perhaps that it should not sound so echoey?
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Senior Forum Staff
 
Posts: 43906
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: Recorded streaming latency issue

Permanent link to this post Posted by kozikowski » Sun Jul 16, 2017 6:34 pm

is it perhaps that it should not sound so echoey?

I bet. I bet your capture is set up wrong and you're listening to the music go through the sound system multiple times.

http://manual.audacityteam.org/man/tuto ... puter.html

Koz
kozikowski
Forum Staff
 
Posts: 36976
Joined: Thu Aug 02, 2007 5:57 pm
Location: Los Angeles
Operating System: OS X 10.9 Mavericks

Re: Recorded streaming latency issue

Permanent link to this post Posted by audino » Mon Jul 17, 2017 12:20 am

steve wrote:
audino wrote:I'm recording a sample streaming and it resulted with latency,

I think "latency" may be the wrong word.
Try describing the problem in more words - is it perhaps that it should not sound so echoey?

I remember Audacity forum's members were more friendly and forgiving as it should be because there are people out there who aren't sound engineer experts (like you seem to be) also people who have different language backgrounds and barriers.
As I said I think latency might be the wrong word, and you got the audio sample so what is the problem?
Sorry if I wasn't able to describe the problem the way you loved to, perhaps you corrected the language part of my post but what about the real problem?
Just I want you know that Audacity is well known BUT right now there are too many free alternatives.
audino
 
Posts: 85
Joined: Fri Jun 15, 2012 8:18 am
Operating System: Windows 7

Re: Recorded streaming latency issue

Permanent link to this post Posted by audino » Mon Jul 17, 2017 12:26 am

kozikowski wrote:
is it perhaps that it should not sound so echoey?

I bet. I bet your capture is set up wrong and you're listening to the music go through the sound system multiple times.
http://manual.audacityteam.org/man/tuto ... puter.html
Koz

Yes I believe that might be the issue, but as you know and Audacity knows, setting Windows' recording isn't an easy task especially when we want to record live streaming.
This is a fresh new system and I had to find the way on how to abilitate the "hidden" stereo mix option then I followed the help document the same you linked but I still wasn't able to find the solution.
Maybe I need to spend more time or just play with another free software.
I wish I used the correct technical language.
audino
 
Posts: 85
Joined: Fri Jun 15, 2012 8:18 am
Operating System: Windows 7

Re: Recorded streaming latency issue

Permanent link to this post Posted by steve » Mon Jul 17, 2017 12:50 am

audino wrote:and you got the audio sample so what is the problem?

The problem is that you know what that recording is supposed to sound like, but we don't. That's why I asked you to clarify what the problem is.

On Windows, the best way to record streaming audio is usually to use "WASAPI loopback" as described here: http://manual.audacityteam.org/man/tuto ... ndows.html
Recording using "Stereo Mix" works for some people, but is a less reliable solution that may produce echoey recordings.
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Senior Forum Staff
 
Posts: 43906
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: Recorded streaming latency issue

Permanent link to this post Posted by kozikowski » Mon Jul 17, 2017 12:52 am

I wish I used the correct technical language.

S'OK. We sometimes hit these things on a dead run and you get sandwiched between other posters.

Perfectly true. Recording sound on a Windows machine is a pain in the neck—largely, oddly enough, from the efforts of the Windows people to keep it from being a pain in the neck.

Windows stopped being general purpose machines a long time ago. They are corporate communication devices now and if that's what you do with them, it's just open them up and start working. It's when you want to do something else that you have to turn off all the normal Windows stuff and turn on the stuff you actually want.

Does the work sound OK if you just flat, plain listen to it? Close Audacity. Get your headphones on and listen carefully to the sound clips. Are they clean? No echoes?

Latency is fancy for delay. If you record several different instruments over each other to form a song (called Overdubbing) and they don't all line up to the beat, that's recording latency and it's adjustable.

Start Audacity.
Audacity > Edit > Preferences > Recording. Turn off everything in the Playthrough panel > OK.

Switch to the browser and start the music. Switch to Audacity and press Record. You won't hear anything, but do you get the bouncing Red recording meters?

Do you hear the music and do you get both sets of sound meters? You shouldn't.

Do that for a minute or two and Stop.

Play the track. You should be able to hear it in your headphones. Is it clean?

Koz
kozikowski
Forum Staff
 
Posts: 36976
Joined: Thu Aug 02, 2007 5:57 pm
Location: Los Angeles
Operating System: OS X 10.9 Mavericks


Return to Windows



Who is online

Users browsing this forum: No registered users and 11 guests