Audacity resets sample rate under ASIO

Help for Audacity 2.x.x on Windows.

ImageThis forum is for Audacity 2.x.x on Windows.

  • Please state which version of Windows you are using, the exact three-section version of Audacity from Help > About Audacity and whether you obtained the .exe installer or the zip.

  • Audacity 1.2.x and 1.3.x are obsolete and no longer supported. If you still have those versions, please upgrade at https://www.audacityteam.org/download/.
    The old forums for those versions are now closed, but you can still read the archives of the 1.2.x and 1.3.x forums.

Audacity resets sample rate under ASIO

Permanent link to this post Posted by roadsterUK » Sat Apr 15, 2017 8:11 pm

I have much the same problem with windows10. I have built both the 32 bit and 64 bit versions and tried the latest alpha source code. I am using an RME babyface USB device and after removing any other audio drivers this is the remaining symptom:-
I set the sampling rate to 192KHz using the RME utility and then start Audacity - it starts correctly, the default project sample rate can be set but it makes no difference to what follows.
I stop the program and attempt to restart - the Audacity logo appears but then the program stops.
I recheck the default RME sample rate and it has changed to 44.1KHz so I change it back to 192 and Audacity will again start successfully ( once).

I'll continue to look into this and report if I find out any more but advice would be very welcome.
roadsterUK
 
Posts: 4
Joined: Sat Apr 15, 2017 8:00 pm
Operating System: Windows 10

Re: Audacity resets sample rate under ASIO

Permanent link to this post Posted by Gale Andrews » Sun Apr 16, 2017 12:56 pm

Thanks for the report. Note this is nothing to do with compiling Audacity per se, nor is it a stated difference between Windows 7 and Windows 10 so I split your post to a new topic in the Windows board with a relevant title.

I think it is a known bug or limitation in Audacity or PortAudio's ASIO support. Are you setting Audacity project rate to 192000 Hz?

A related case has been reported on MOTU devices, where if MOTU is set to 44100 Hz, Audacity changes the MOTU rate to 192000 when it plays or records first time even though Audacity project rate is set to 44100 Hz. When you stop playback or recording, Audacity sets MOTU to 44100 Hz and thence plays or records at 44100 Hz. Do you see that, if you want to test?


Gale

roadsterUK wrote:I have much the same problem with windows10. I have built both the 32 bit and 64 bit versions and tried the latest alpha source code. I am using an RME babyface USB device and after removing any other audio drivers this is the remaining symptom:-
I set the sampling rate to 192KHz using the RME utility and then start Audacity - it starts correctly, the default project sample rate can be set but it makes no difference to what follows.
I stop the program and attempt to restart - the Audacity logo appears but then the program stops.
I recheck the default RME sample rate and it has changed to 44.1KHz so I change it back to 192 and Audacity will again start successfully ( once).

I'll continue to look into this and report if I find out any more but advice would be very welcome.
________________________________________FOR INSTANT HELP: (Click on Link below)
* * * * * Tips * * * * * Tutorials * * * * * Quick Start Guide * * * * * Audacity Manual
Gale Andrews
Quality Assurance
 
Posts: 26093
Joined: Fri Jul 27, 2007 12:02 am
Operating System: Windows 10

Re: Audacity resets sample rate under ASIO

Permanent link to this post Posted by roadsterUK » Mon Apr 17, 2017 3:37 pm

In a previous post which is yet to appear in this thread I suggested that this array
Code: Select all
static ASIOSampleRate defaultSampleRateSearchOrder_[]
     = {192000.0, 44100.0, 48000.0, 32000.0, 24000.0, 22050.0, 88200.0, 96000.0,
         16000.0, 12000.0, 11025.0, 9600.0, 8000.0 };
in pa_asio.cpp was implicated in these problems and in the above version I have moved 192000.0 to be the first element. Sure enough this does overcome the problem of the device rate being set back to 44.1KHz when Audacity is closed. It also prevents problem which only affects Windows 10 namely that Audacity fails to start on all but the first run until the rate is externally reset to 192KHz. For my purposes this does make this implementation useable because I almost always use 192KHz. However its not a true fix because if a file at a different sample rate is loaded it only plays properly at the second attempt because the device rate is only set when the play button is pressed and that is apparently too late.

I also have a problem related to the failure to recognise Lame and FFMPEG libraries but I will post this separately if I can't find what I have done wrong.
roadsterUK
 
Posts: 4
Joined: Sat Apr 15, 2017 8:00 pm
Operating System: Windows 10

Re: Audacity resets sample rate under ASIO

Permanent link to this post Posted by Gale Andrews » Tue Apr 18, 2017 1:49 pm

roadsterUK wrote:In a previous post which is yet to appear in this thread I suggested that this array
Code: Select all
static ASIOSampleRate defaultSampleRateSearchOrder_[]
     = {192000.0, 44100.0, 48000.0, 32000.0, 24000.0, 22050.0, 88200.0, 96000.0,
         16000.0, 12000.0, 11025.0, 9600.0, 8000.0 };
in pa_asio.cpp was implicated in these problems and in the above version I have moved 192000.0 to be the first element. Sure enough this does overcome the problem of the device rate being set back to 44.1KHz when Audacity is closed. It also prevents problem which only affects Windows 10 namely that Audacity fails to start on all but the first run until the rate is externally reset to 192KHz. For my purposes this does make this implementation useable because I almost always use 192KHz. However its not a true fix because if a file at a different sample rate is loaded it only plays properly at the second attempt because the device rate is only set when the play button is pressed and that is apparently too late.

Thanks for your researches. Is Audacity the only application that has these problems? If not, you could perhaps also discuss it on the PortAudio mailing list.


Gale
________________________________________FOR INSTANT HELP: (Click on Link below)
* * * * * Tips * * * * * Tutorials * * * * * Quick Start Guide * * * * * Audacity Manual
Gale Andrews
Quality Assurance
 
Posts: 26093
Joined: Fri Jul 27, 2007 12:02 am
Operating System: Windows 10


Return to Windows



Who is online

Users browsing this forum: No registered users and 12 guests