Slide effect - HELP NEEDED

Using Nyquist scripts in Audacity.
Post and download new plug-ins.

If you require help using Audacity, please post on the forum board relevant to your operating system:
Windows
Mac OS X
GNU/Linux and Unix-like

Re: Slide effect - HELP NEEDED

Permanent link to this post Posted by Michael Kazmierski » Fri Jul 07, 2017 12:20 am

Well, the only reason why I don't ever want to try 2.1.2 is because it makes no sense at all for a plugin to insert unwanted silence and latency which might not be corrected, plus I'm not used to having effects perform in real-time. When I replaced *track* with just S, it doesn't work.
Michael Kazmierski
 
Posts: 39
Joined: Wed Aug 17, 2016 1:06 am
Operating System: Windows 7

Re: Slide effect - HELP NEEDED

Permanent link to this post Posted by steve » Fri Jul 07, 2017 12:24 am

Michael Kazmierski wrote: it makes no sense at all for a plugin to insert unwanted silence and latency which might not be corrected

What are you referring to?
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 44465
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: Slide effect - HELP NEEDED

Permanent link to this post Posted by Michael Kazmierski » Fri Jul 07, 2017 12:27 am

I can remember for some reason, whichever plugins that can be changed in real-time when you play a file, I remember something about the effect having to insert latency so it could be applied. I'm not sure if this is still true in 2.1.2, but to me it just doesn't make sense.
All I did with the code was to change *track&* to S, and version 4 to version 3. The plugin appears, but when I run it, it says Nyquist did not return audio.
Michael Kazmierski
 
Posts: 39
Joined: Wed Aug 17, 2016 1:06 am
Operating System: Windows 7

Re: Slide effect - HELP NEEDED

Permanent link to this post Posted by steve » Fri Jul 07, 2017 1:07 am

Michael Kazmierski wrote: remember something about the effect having to insert latency so it could be applied.

The bug that you are referring to affects the preview of some third party plug-ins. It does not affect how the effect is applied, and does not affect any of the effects that are shipped with Audacity. It also does not affect Nyquist effects.
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 44465
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: Slide effect - HELP NEEDED

Permanent link to this post Posted by steve » Fri Jul 07, 2017 1:36 am

Michael Kazmierski wrote:The plugin appears, but when I run it, it says Nyquist did not return audio.

Try running the effect using the Debug button rather than the OK button.
What does it say in the debug window?
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 44465
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Previous

Return to Nyquist



Who is online

Users browsing this forum: No registered users and 1 guest