Slide effect - HELP NEEDED

Archive of Nyquist Plug-ins.
Many of the plug-ins here will be available on the Audacity Wiki.

This Forum is an archive of old topics concerning Nyquist plug-ins.

Feedback and questions relating to topics may be posted, but please
DO NOT POST NEW TOPICS HERE.

New plug-ins may be posted on the New Plug-Ins board.
Other posts relating to Nyquist should be posted to the main Nyquist board.

The main repository for Audacity/Nyquist Plug-ins is on the Audacity Wiki.

Re: Slide effect - HELP NEEDED

Permanent link to this post Posted by Michael Kazmierski » Fri Jul 07, 2017 12:20 am

Well, the only reason why I don't ever want to try 2.1.2 is because it makes no sense at all for a plugin to insert unwanted silence and latency which might not be corrected, plus I'm not used to having effects perform in real-time. When I replaced *track* with just S, it doesn't work.
Michael Kazmierski
 
Posts: 48
Joined: Wed Aug 17, 2016 1:06 am
Operating System: Windows 7

Re: Slide effect - HELP NEEDED

Permanent link to this post Posted by steve » Fri Jul 07, 2017 12:24 am

Michael Kazmierski wrote: it makes no sense at all for a plugin to insert unwanted silence and latency which might not be corrected

What are you referring to?
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 45047
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: Slide effect - HELP NEEDED

Permanent link to this post Posted by Michael Kazmierski » Fri Jul 07, 2017 12:27 am

I can remember for some reason, whichever plugins that can be changed in real-time when you play a file, I remember something about the effect having to insert latency so it could be applied. I'm not sure if this is still true in 2.1.2, but to me it just doesn't make sense.
All I did with the code was to change *track&* to S, and version 4 to version 3. The plugin appears, but when I run it, it says Nyquist did not return audio.
Michael Kazmierski
 
Posts: 48
Joined: Wed Aug 17, 2016 1:06 am
Operating System: Windows 7

Re: Slide effect - HELP NEEDED

Permanent link to this post Posted by steve » Fri Jul 07, 2017 1:07 am

Michael Kazmierski wrote: remember something about the effect having to insert latency so it could be applied.

The bug that you are referring to affects the preview of some third party plug-ins. It does not affect how the effect is applied, and does not affect any of the effects that are shipped with Audacity. It also does not affect Nyquist effects.
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 45047
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: Slide effect - HELP NEEDED

Permanent link to this post Posted by steve » Fri Jul 07, 2017 1:36 am

Michael Kazmierski wrote:The plugin appears, but when I run it, it says Nyquist did not return audio.

Try running the effect using the Debug button rather than the OK button.
What does it say in the debug window?
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 45047
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: Slide effect - HELP NEEDED

Permanent link to this post Posted by steve » Thu Oct 12, 2017 1:34 pm

The "Sliding Speed Change" plug-in is now available on the Audacity wiki: http://wiki.audacityteam.org/wiki/Nyqui ... eed_Change
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 45047
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Previous

Return to Plug-in Archive



Who is online

Users browsing this forum: No registered users and 0 guests