Page 1 of 1

Firefox 58 Reports Insecure Connection

Permanent link to this postPosted: Tue Feb 06, 2018 5:16 am
Posted by jopower
I just joined this forum today and, upon 1st login of my password a few minutes ago, was notified by Firefox 58 that it was an insecure connection and my actions "could" be seen. This is the 1st time I have received such a notice on a forum in some years. The FF info box recommended that I try to type in a "HTTPS" prefix for your URL. However, FF isn't showing any HTTP for me to change in the address bar.

In defense of my own computer, I am using a one-of-a-kind password, and am using a modem hardware firewall and "Private Firewall" is my software firewall, so I feel reasonably safe. However, to assure us users, it would appear that the Audacity forum Sysops should examine the security for this forum ASAP. Thank you.

Re: Firefox 58 Reports Insecure Connection

Permanent link to this postPosted: Tue Feb 06, 2018 11:25 am
Posted by cyrano
Don't worry.

The latest Firefox is a bit over cautious. I don't know why it is complaining, but it's not something to worry about. SSL is working. Maybe the forum's admin needs to disable a few old and insecure encryption protocols?

But everything you post here is de facto public. So there's nothing to snoop, except your password. And there's no incentive to snoop your password, as there's no real profit in it. Only spammers might be interested, but they could also just register their own forum account. But even the dumbest spammer will notice that as a waist of time, since this forum is well policed by the mods.

Re: Firefox 58 Reports Insecure Connection

Permanent link to this postPosted: Tue Feb 06, 2018 12:14 pm
Posted by steve
cyrano wrote:Maybe the forum's admin needs to disable a few old and insecure encryption protocols?

The forum, and the other Audacity websites, use highly secure, professional SSL authentication across the board whenever "https://" is used as the web address.

So as to avoid breaking compatibility, the old (less secure) "http://" form of addresses are still supported for the time being, but will eventually be disabled (http:// requests will be redirected to https://).

It is highly recommended that anyone that has bookmarked any Audacity web page with the old "http://" address, update their bookmarks to "https://".

jopower wrote:The FF info box recommended that I try to type in a "HTTPS" prefix for your URL. However, FF isn't showing any HTTP for me to change in the address bar.

This is normal for recent versions of Firefox. It only shows the protocol part of the address (the "....://" part) for "https://" and not "http://".
Just type (without quotes) "https://" at the start of the address.
and / or:
bookmark: https://forum.audacityteam.org/
and / or:
use this link to log-in: https://forum.audacityteam.org/ucp.php?mode=login