Compile of SVN Audacity fails on Fedora 23 [SOLVED]

Building and customizing Audacity from the source code.

If you require help using Audacity, please post on the forum board relevant to your operating system:
Windows
Mac OS X
GNU/Linux and Unix-like

Compile of SVN Audacity fails on Fedora 23 [SOLVED]

Permanent link to this post Posted by Etna » Sat Jan 09, 2016 12:58 pm

I'm currently attempting to compile the SVN version of Audacity on Fedora 23, x64.

As usual, all directions described on http://wiki.audacityteam.org/wiki/Developing_On_Linux#Compiling_on_Unix and http://wiki.audacityteam.org/wiki/Compiling_Audacity_for_Beginners#Step_2:_Download_and_uncompress_wxGTK have been followed.

Additional information about my setup:
- I have ffmpeg and a bunch of additional libs scattered around /home/etna/Applications/GIMP/depends/lib and /home/etna/Downloads/avdepends/lib

My ./configure is as follows:
Code: Select all
CFLAGS='-fPIC' LDFLAGS="-L/home/etna/Downloads/avdepends/lib:/home/etna/Applications/GIMP/depends/lib" CPPFLAGS="-I/home/etna/Downloads/avdepends/include:/home/etna/Applications/GIMP/depends/include" PKG_CONFIG_PATH=/home/etna/Downloads/avdepends/lib/pkgconfig:/home/etna/Applications/GIMP/depends/lib/pkgconfig:$PKG_CONFIG_PATH ./configure --prefix=/home/etna/Applications/Audacity --with-libvorbis --with-libflac --with-ffmpeg=system --with-lame --with-libid3tag --with-libmad --with-libsndfile=system


When running make, the build fails and claims that sndfile.h cannot be found even though it located at /home/etna/Downloads/avdepends/include as defined in the ./configure step, so i copied the .h files temporally to /usr/include and the build proceeded from there. However, it later fails with multiple errors about ffmpeg.h having conflicting definitions for a number of items. as shown in the pastebin link http://pastebin.com/N3BUnQHm

Any assistance will be greatly appreciated
Etna
 
Posts: 5
Joined: Sun Sep 28, 2014 2:10 pm
Operating System: Linux Fedora/RHEL

Re: Compile of SVN Audacity fails on Fedora 23

Permanent link to this post Posted by steve » Sat Jan 09, 2016 1:21 pm

The FFmpeg library can be a pain as there are frequently big changes between versions that break things when trying to link.
I'd suggest that you first try to build without FFmpeg (something like .configure --without-ffmpeg but check in .configure -h).
If that builds successfully, do
Code: Select all
make distclean

then try configure with:
Code: Select all
--disable-dynamic-loading
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 45973
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: Compile of SVN Audacity fails on Fedora 23

Permanent link to this post Posted by Etna » Sat Jan 09, 2016 1:34 pm

steve wrote:The FFmpeg library can be a pain as there are frequently big changes between versions that break things when trying to link.
I'd suggest that you first try to build without FFmpeg (something like .configure --without-ffmpeg but check in .configure -h).
If that builds successfully, do
Code: Select all
make distclean

then try configure with:
Code: Select all
--disable-dynamic-loading


Thanks for replying. Building with --without-ffmpeg returned another set of errors at the linking stage: http://pastebin.com/pevYtgrk

It looks like another dependency is missing, but I can't figure out what it is?
Etna
 
Posts: 5
Joined: Sun Sep 28, 2014 2:10 pm
Operating System: Linux Fedora/RHEL

Re: Compile of SVN Audacity fails on Fedora 23

Permanent link to this post Posted by steve » Sat Jan 09, 2016 3:53 pm

Doh, just noticed that you said "SVN version".
Audacity no longer uses SVN - that's the old, unmaintained Sourceforge repository. The current Audacity code is on GitHub, and it requires WxGTK 3.0 (preferably 3.0.2).
See: http://wiki.audacityteam.org/wiki/Developing_On_Linux
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 45973
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu

Re: Compile of SVN Audacity fails on Fedora 23

Permanent link to this post Posted by Etna » Sat Jan 09, 2016 3:58 pm

Trashed the SVN copy and cloned the GitHub version.

The Git version still fails with the same ffmpeg conflicts when built normally, but succeeded with --disable-dynamic-loading. I guess the issue is solved?
Etna
 
Posts: 5
Joined: Sun Sep 28, 2014 2:10 pm
Operating System: Linux Fedora/RHEL

Re: Compile of SVN Audacity fails on Fedora 23 [SOLVED]

Permanent link to this post Posted by steve » Sat Jan 09, 2016 4:14 pm

Etna wrote:The Git version still fails with the same ffmpeg conflicts when built normally, but succeeded with --disable-dynamic-loading.

Excellent, that was quick - you must have a faster machine than me ;)
I'm not sure why, but Audacity is a lot less fussy about the FFmpeg build when using --disable-dynamic-loading. It's a workaround that Ubuntu uses on their repository builds. Audacity may eventually move from using FFmpeg to using GStreamer which will hopefully make this issue a thing of the past.

I'll mark this topic as "solved".
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Site Admin
 
Posts: 45973
Joined: Sat Dec 01, 2007 11:43 am
Operating System: Linux *buntu


Return to Compiling Audacity



Who is online

Users browsing this forum: No registered users and 3 guests