Page 1 of 1

Exporting to wav, aiff, au for cdrecord

Permanent link to this postPosted: Tue Nov 10, 2009 3:16 am
Posted by Machtyn
Using the 1.3.3-beta version of Audacity, I attempted to export my project as a [22050|41000]KHz, [16|32] bit, [wav|aiff|au] file. When I tried to create my audio disc using cdrecord, I would always get one of the two following errors
Code: Select all
cdrecord: Inappropriate audio coding in myfile.wav

or
Code: Select all
cdrecord: Bad audio track size 135828054 for track 01.
cdrecord: Audio tracks must be at least 705600 bytes and a multiple of 2352.
cdrecord: See -pad option.

for an .au or .aiff file.

My cdrecord line as always:
Code: Select all
C:cdrtools>cdrecord.exe -v dev=5,1,0 driveropts=burnfree -eject -dao -audio myfile.xxx

(where .xxx was one of .aiff, .au, or .wav, depending on the file I was attempting to burn at the time.)

Was I exporting incorrectly, have an incorrect/buggy version of cdrecord, or something else? Windows Media Player also had trouble with these exported files.

I finally gave up, exported as an mp3 and that worked. But I would like an answer because I'd rather work with uncompressed file in the future.

Re: Exporting to wav, aiff, au for cdrecord

Permanent link to this postPosted: Tue Nov 10, 2009 3:24 am
Posted by steve
Your mention of ".au" files is ringing alarm bells.
You understand that the .au files that Audacity creates in the project data folder are just the data for Audacity and not proper audio files?

Re: Exporting to wav, aiff, au for cdrecord

Permanent link to this postPosted: Tue Nov 10, 2009 3:50 am
Posted by billw58
Machtyn wrote:Using the 1.3.3-beta version of Audacity, I attempted to export my project as a [22050|41000]KHz, [16|32] bit, [wav|aiff|au] file.


Stick to 44100 16-bit WAV. CD burning software usually requires 44100 16-bit, although some can convert on the fly.

When I tried to create my audio disc using cdrecord, I would always get one of the two following errors
Code: Select all
cdrecord: Inappropriate audio coding in myfile.wav

or
Code: Select all
cdrecord: Bad audio track size 135828054 for track 01.
cdrecord: Audio tracks must be at least 705600 bytes and a multiple of 2352.
cdrecord: See -pad option.

for an .au or .aiff file.


Look at the bottom of the Audacity project window. To the right of the Snap to control are three boxes with drop-down menus. Click on one of those menus then choose "CDDA frames". Then set Snap to ON. Now all your edits will fall on boundaries of 2352 bytes, and cdrecord will be happy. Although it looks from the error message that there is a "pad" option to pad the end of each track to fill it to a multiple of 2352 bytes. You may not want to do this as it may cause a click on playback.

I finally gave up, exported as an mp3 and that worked. But I would like an answer because I'd rather work with uncompressed file in the future.


I can't understand why cdrecord would choke on a 44100 Hz 16-bit WAV file. But then I don't know the program.

-- Bill

Re: Exporting to wav, aiff, au for cdrecord

Permanent link to this postPosted: Tue Nov 10, 2009 4:22 am
Posted by steve
There's a thread here: http://lists.debian.org/cdwrite/2004/01/msg00227.html

> Works for me, although I put the -pad before the --audio. Don't know if
> that's a clue or not

Ah yes, good clue, man cdrecord says -pad affects the following
track(s) until -nopad is used.


(see link for full context)

Re: Exporting to wav, aiff, au for cdrecord

Permanent link to this postPosted: Thu Nov 12, 2009 6:38 am
Posted by Machtyn
Thanks for the replies, all.

I will definitely try explicitly using the -nopad option. Also, I'll make sure to use the CDDA timecoding on the audio file. I've had it set to 29.97fps for some film editing I've done.

stevethefiddle: The au file is a simple audio file format from Sun Microsystems. The aup is the audacity project file... oh, yeah, I see... There are a large number of .au files within the project's folder. It looks like those for undo/redo edits and other markings.