Audacity won't work with Realtek HD Card

This section is now closed.

Audacity 1.2.x is now obsolete. Please use the current Audacity 2.0.x version.

The final version of Audacity for Windows 98/ME is the legacy 2.0.0 version.

Re: Audacity won't work with Realtek HD Card

Permanent link to this post Posted by whomper » Sun Mar 07, 2010 2:17 pm

stevethefiddle wrote:I found a computer at work that had Realtek HD on board, so I enabled it so that I could have a look.
I think there are many variations of this, but here's a screenshot of the one I tried:

RealTek HD Stereo Mix.GIF

To access this control panel, I double clicked on the speaker icon in the lower right corner of the screen.
Note that I have selected the "Mxer" tab.
The upper half shows the "Playback" settings and the lower half shows the "Record" (input) settings.

By default, many of the sliders are hidden.
To make the hidden sliders available, click on the "spanner" icon near the "volume knob".

The left and right chevrons "< >" that are at the bottom right of the playback section allow you to scroll through the available sliders. If there are too many sliders to fit on the screen, then these chevrons appear.

You will also note that there are no sliders in the record section, but level adjustment can be achieved by "turning" the Record Level volume knob (click on it and drag)

Note the red crosses on the speaker icons in the Record section - these inputs are muted. In this screenshot, all inputs are muted apart from "Stereo Mix".

I think it is possible to enable individual sliders in the record section, but I didn't have much time to play with it (I was supposed to be working).


yup
same as i posted several times previously

clicking the wrench gives you a choice of channels to have sliders for
it does nothing for the sliders themselves

you need a newer driver
mine is 5408 and works
dell had a note that earlier ones were fatally flawed or somesuch

you canNOT enable record sliders
you have to mute them
and use the wheel on the left for volume

how did you capture that window so it works in the message ?
whomper
Probationer (now banned)
 
Posts: 1252
Joined: Sat Jan 23, 2010 9:36 pm

Re: Audacity won't work with Realtek HD Card

Permanent link to this post Posted by whomper » Sun Mar 07, 2010 6:41 pm

stevethefiddle wrote:We have had a lot of questions about this very thing. Unfortunately there seem to be many variations in the RealTek HD drivers that make it different from one machine to another which makes it difficult (impossible) to give a definitive answer. However, most users have eventually found a way to switch to "stereo mix" (or whatever they decide to call it), but finding the place to do it apparently difficult to find in many cases.

A useful tool to help you in your hunt for the magic switch is to have Audacity open and activate the recording level meter by clicking on it. You can then instantly see if Audacity is receiving a signal.


in the realtek driver
unmute stereo mixits under the mixer tab
click on the tray icon to bring up the realtek panel
or hunt it down throught start/settings/controlpanel/....
whomper
Probationer (now banned)
 
Posts: 1252
Joined: Sat Jan 23, 2010 9:36 pm

Re: Audacity won't work with Realtek HD Card

Permanent link to this post Posted by whomper » Sun Mar 07, 2010 6:42 pm

Keefy wrote:Hi Guys It's Keefy again
If there is anybody out there who has found the magic switch please tell us!!
Our machine is running windows XP Pro with the dreaded Realtek HD Card (driver version 5.10.0.5296)
If you are running Audacity with this card and a different driver version please let us know.

Best Regards
Keefy :D


you need 5408 driver or later
earlier drivers are faulty
dl it at dell or realtek

click on the icon in the tray
go to mixer
on bottom under record unmute stereo mix
then select it in audacity
whomper
Probationer (now banned)
 
Posts: 1252
Joined: Sat Jan 23, 2010 9:36 pm

Re: Audacity won't work with Realtek HD Card

Permanent link to this post Posted by mellopete » Wed May 12, 2010 8:58 pm

In case anyone can't see "stereo mix" under recording devices in Windows 7 (control panel -> sound -> recording tab). Try right clicking in the list and select "Show disabled devices". Then set it as default, and select it as the recording device in Audacity (edit -> preferences). Worked for me on Realtek ALC889a.
mellopete
 
Posts: 1
Joined: Wed May 12, 2010 8:53 pm

Re: Audacity won't work with Realtek HD Card

Permanent link to this post Posted by kltchamp » Tue Aug 03, 2010 3:56 pm

I have followed the original instructions that "mh28450" posted and now I am able to record.
However, it will not let me distinguish between "microphone" and "stereo mix".
When I try to mute microphone it won’t record through stereo mix.

I am trying to record what my pc plays (streaming audio) and not do it through the microphone.

Please Help!
kltchamp
 
Posts: 1
Joined: Tue Aug 03, 2010 3:47 pm

Did you activate your Realtek _speakers_?

Permanent link to this post Posted by noltan » Sun Nov 07, 2010 6:22 pm

Hi!

I had the same problem, and did everything described here and elsewhere.
My solution: I have always USB speakers plugged in and it didn't occur to me that those could be the problem. But, lo and behold, when I activated my laptops built-in speakers (also Realtek), it worked! I can now record what I hear. Although, worth to note, I still don't get the drop-down menu that's supposed to have a 'What you hear' option, it's just gray and not clickable.

WHAT I DID
In Audacity
I changed the Recording Device in Edit -> Preferences -> Audio/IO to "Stereo mix (Realtek High Defini" (sic)

In Windows (Vista, by the way)
In the Sound settings – accessible through the Control Panel or by right-clicking the volume icon – I did 2 things.
1. In the Recording tab I activated Stereo mix (Realtek High Definition Audio written under it). Right-click, activate.
2. The crucial step that made it work: In the Playback tab, activate your laptop speakers. And you're done!

I hope it works for you! I actually registered on this forum just to share this.
Good luck!
noltan
 
Posts: 1
Joined: Sun Nov 07, 2010 5:53 pm

Re: Audacity won't work with Realtek HD Card

Permanent link to this post Posted by joasis » Wed Jan 12, 2011 6:25 am

i have a Dell Vostro 200 running Vista home premium 32 bit. i finally got Audacity to work by downloading the driver program directly from RealTek. The link is:

http://www.realtek.com/downloads/downlo ... Down=false

Install it and then use the newly installed RealTek Audio Manager to activate the Stereo Mix audio device.
joasis
 
Posts: 1
Joined: Wed Jan 12, 2011 6:15 am

Re: Audacity won't work with Realtek HD Card

Permanent link to this post Posted by neomega702 » Thu Jan 27, 2011 1:30 am

Here is the solution for this problem. I have windows 7 64bits.
Do this:
Credit goes to tuney from videohelp.com

Go to Sound in the Control Panel's classic view
Select the Recording tab and right-click any of the devices listed.
Check "Show Disabled Devices" and "Show Disconnected Devices".
Stereo Mix should show up. Set it as default

IT WORKS!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
neomega702
 
Posts: 1
Joined: Thu Jan 27, 2011 1:27 am

Re: Audacity won't work with Realtek HD Card

Permanent link to this post Posted by steve » Thu Jan 27, 2011 1:49 am

Thanks neomega702, that's also what it says in the Audacity documentation.
There's also some other tips for when that doesn't work:
http://wiki.audacityteam.org/wiki/Mixer ... trol_Panel
9/10 questions are answered in the FREQUENTLY ASKED QUESTIONS (FAQ)
steve
Senior Forum Staff
 
Posts: 32924
Joined: Sat Dec 01, 2007 11:43 am

Re: Audacity won't work with Realtek HD Card

Permanent link to this post Posted by jhaskins75 » Mon Jan 31, 2011 4:43 am

To activate your sound mix features on any windows platform..Right click your sound icon or go to your control center / sound / right click in the empty space/ click properties and it will display the sound mix icon. Click on it/ engage then click on microphone icon, and mute or disengage the mike feature. This will allow audacity to record directly via the sound card. In your realtek audio manager, search for recording volume control and reduce to a level between 18 and 35. Anything above 35 will cause gain distortion. [ The recording level is a slider, and when you put your curser on the slider and move it either way, it shows the percentage from 0 to 100 which translates in recording level volume ]
jhaskins75
 
Posts: 19
Joined: Sat Apr 03, 2010 11:19 pm

PreviousNext

Return to Windows



Who is online

Users browsing this forum: No registered users and 6 guests